1114. Family Property (25)

1114. Family Property (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

dfs

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int n,smallid,cou;
double sumset,sumarea;
int visit[10010];
vector<int>adj[10010];
vector<int>name;
struct node{
	double estate;
	double area;
}stu[10010];
struct family{
	int id;
	int personnum;
	double avgsets;
	double avgarea;
};
vector<family>ans;
void dfs(int s){
	if(visit[s]==1){
		return;
	}
	visit[s]=1;
	if(s<smallid){
		smallid=s;
	}
	cou++;
	sumset=sumset+stu[s].estate;
	sumarea=sumarea+stu[s].area;
	int i;
	for(i=0;i<adj[s].size();i++){
		int next=adj[s][i];
//		if(visit[next]==0){
			dfs(next);
//		}		
	}
}
bool cmp(family a,family b){
	if(fabs(a.avgarea-b.avgarea)>0.00001){
		return a.avgarea>b.avgarea;
	}
	else{
		return a.id<b.id;
	}
}
int main(){
	int i,j,k,id,mother,father,child;
	double estate,area;
	scanf("%d",&n); 
	for(i=0;i<n;i++){
		scanf("%d %d %d %d",&id,&father,&mother,&k);
		name.push_back(id);
		if(father!=-1){
			adj[id].push_back(father);
			adj[father].push_back(id);
			name.push_back(father);
		}
		if(mother!=-1){
			adj[id].push_back(mother);
			adj[mother].push_back(id);
			name.push_back(mother);
		}
		for(j=0;j<k;j++){
			scanf("%d",&child);
			adj[id].push_back(child);
			adj[child].push_back(id);
			name.push_back(child);
		}
		scanf("%lf %lf",&stu[id].estate,&stu[id].area);
	}
	for(i=0;i<name.size();i++){
		if(visit[name[i]]==0){
			smallid=name[i];
			cou=0;
			sumset=sumarea=0;
			dfs(name[i]);
			family temp={smallid,cou,sumset/cou,sumarea/cou};
			ans.push_back(temp);
		}
	}
	sort(ans.begin(),ans.end(),cmp);
	printf("%d\n",ans.size());
	for(i=0;i<ans.size();i++){
		printf("%04d %d %.3lf %.3lf\n",ans[i].id,ans[i].personnum,ans[i].avgsets,ans[i].avgarea);
	}
}


在JavaScript中,你可以使用`addEventListener`方法来监听`id`为"body"的元素的`style`属性变化,特别是关于`fontFamily`的变化。首先,你需要创建一个事件处理器函数,这个函数会在`style.fontFamily`属性改变时被调用: ```javascript // 获取body元素并设置初始的字体家族 const bodyElement = document.getElementById("body"); let initialFontFamily = bodyElement.style.fontFamily; // 监听style.fontFamily的变更 bodyElement.addEventListener('propertychange', function(event) { if (event.propertyName === 'fontSize') { // 只检查fontFamily属性 const newFontFamily = bodyElement.style.fontFamily; // 在这里可以处理新旧字体家族的差异 console.log(`Font family changed from ${initialFontFamily} to ${newFontFamily}`); // 更新初始值以便于下次比较 initialFontFamily = newFontFamily; } }); ``` 请注意,`propertychange`事件并不是所有浏览器都支持,对于更精确的字体家族更改监控,通常推荐使用MutationObserver API,它可以观察DOM的结构变动。 ```javascript // 使用MutationObserver const observer = new MutationObserver((mutationsList, observer) => { mutationsList.forEach(mutation => { if (mutation.type === 'attributes' && mutation.attributeName === 'style') { const styleObject = window.getComputedStyle(bodyElement); const fontFamily = styleObject.getPropertyValue('font-family'); // ...处理字体家族变更... } }); }); observer.observe(bodyElement, { attributes: true, attributeFilter: ['style'] }); ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值