1103. Integer Factorization (30)
The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n1^P + ... nK^P
where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62+ 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL
If there is no solution, simple output "Impossible".
Sample Input 1:169 5 2Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2Sample Input 2:
169 167 3Sample Output 2:
Impossible
参照算法笔记P280
递归真的是妙啊~
#include<stdio.h>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
int n,p,k;
vector<int>tmp,ans;
int maxsum=-1;
int getfac(){
int i=1;
while((int)(pow(i,p))<=n){
i++;
}
return i-1;
}
void dfs(int index,int nowk,int sum,int sumfac){
if(nowk==k&&sum==n&&sumfac>maxsum){
ans=tmp;
maxsum=sumfac;
return ;
}
if(index==0||nowk>k||sum>n){
return;
}
tmp.push_back(index);
dfs(index,nowk+1,sum+(int)pow(index,p),sumfac+index);
tmp.pop_back();
dfs(index-1,nowk,sum,sumfac);
}
int main(){
int i;
scanf("%d %d %d",&n,&k,&p);
int index=getfac();
dfs(index,0,0,0);
if(maxsum==-1){
printf("Impossible");
}
else{
printf("%d = %d^%d",n,ans[0],p);
for(i=1;i<ans.size();i++){
printf(" + %d^%d",ans[i],p);
}
}
}