Uva12716:GCD XOR

Given an integer N, find how many pairs (A, B) are there such that: gcd(A, B) = A xor B where
1 ≤ B ≤ A ≤ N.
Here gcd(A, B) means the greatest common divisor of the numbers A and B. And A xor B is the
value of the bitwise xor operation on the binary representation of A and B.

Input

The first line of the input contains an integer T (T ≤ 10000) denoting the number of test cases. The
following T lines contain an integer N (1 ≤ N ≤ 30000000).

Output

For each test case, print the case number first in the format, ‘Case X:’ (here, X is the serial of the
input) followed by a space and then the answer for that case. There is no new-line between cases.

Sample Input
2
7
20000000
Sample Output
Case 1: 4
Case 2: 34866117
Explanation

Sample 1: For N = 7, there are four valid pairs: (3, 2), (5, 4), (6, 4) and (7, 6).

【题目描述】

给你一个正整数n,问你区间[1, n]中有多少无序数对(a, b)满足 gcd(a,b)=ab

【简要题解】

假设 a>b ,我们可以观察到

ab>=ab

gcd(a,b)ab

第一个不等式是显然的。
而由于 gcd(a,b)|b gcd(a,b)|b
所以 gcd(a,b)|ab ,所以第二个不等式也成立
所以就有 gcd(a,b)=ab
我们可以枚举 c=gcd(a,b) ,再枚举 a=ci ,判断 ac 是否等于 ac 即可

时间复杂度: O(nlogn)

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

int solve(int n)
{
    int ans = 0, e = n >> 1;
    for(int c = 1; c <= e; ++c)
        for(int a = c << 1; a <= n; a += c)
            if((a^c) == a-c) ans++;
    return ans;
}

int main()
{
    int n; cin >> n;
    cout << solve(n) << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值