HDU 6103-Kirinriki

Kirinriki

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1812    Accepted Submission(s): 745


题目链接:点击打开链接

Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.

 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.

Sample Input
1
5
abcdefedcb
 


Sample Output
5


Hint
[0, 4] abcde
[5, 9] fedcb

The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5



题意:

给定一个整数m和一个字符串s,规定两个字符串的距离disA,B=i=0n1|AiBn1i| ,在母串s中找出距离小于或等于m的最长子串的长度,两个子串的长度相等。


分析:

本题用到尺取法,首先正方向枚举每一个点,固定这个点作为开始的左边界。然后再依次往后确定右边界,定好边界,再确定好中点,依次从左边界和右边界的位置取元素,向中间逼近,直到dis>m,这时候更新长度最大值,将边界的值减去,并且把本轮中超出m的那组数也减去,便于再次循环操作,直到dis<=m
,这样再开始确定右边界和中点再进行这样的操作。注意的是,要考虑到全部的区间,所以最后还要讲s倒置,再计算一遍。






#include<bits/stdc++.h>
using namespace std;
char s[5010];
int ls,m,ans;
void solve()
{
    for(int i=2; i<=ls; i++)///i用来确定区间的右边界
    {
		int o=i/2,l=0,n=0,sum=0;///o是中点,l是左边界,n是用统计子串中元素的个数,sum是用来计算对应字符的距离
        for(int j=0; j<o; j++)///从0往区间中点缩进
        {
            sum+=abs(s[j]-s[i-j-1]);///因为区间确定,左右对称的字符相应求差,即两个子串中字符对应的距离
            if(sum<=m)///满足限制条件,则子串长度n++
            {
                n++;
		ans = max(ans,n);//保存最长的子串
            }
            else
            {
                sum-=abs(s[l]-s[i-l-1]);///弹出靠近边界的两个
		sum-=abs(s[j]-s[i-j-1]);//并且减去让sum超出m的值,因为再次循环的时候又会加上
                n--;
                j--;
                l++;///一直到满足条件再往里缩进
            }
        }
    }
}
int main()
{
	int T;
	scanf("%d",&T);
    while(T--)
    {
		scanf("%d%s",&m,s);
		ls=strlen(s);
		ans=0;
        solve();
        reverse(s,s+ls); /// 正反各计算一遍
        solve();
		printf("%d\n",ans);
    }
    returno;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值