poj1275 Cashier Employment

Description

A supermarket in Tehran is open 24 hours a day every day and needs a number of cashiers to fit its need. The supermarket manager has hired you to help him, solve his problem. The problem is that the supermarket needs different number of cashiers at different times of each day (for example, a few cashiers after midnight, and many in the afternoon) to provide good service to its customers, and he wants to hire the least number of cashiers for this job.

The manager has provided you with the least number of cashiers needed for every one-hour slot of the day. This data is given as R(0), R(1), ..., R(23): R(0) represents the least number of cashiers needed from midnight to 1:00 A.M., R(1) shows this number for duration of 1:00 A.M. to 2:00 A.M., and so on. Note that these numbers are the same every day. There are N qualified applicants for this job. Each applicant i works non-stop once each 24 hours in a shift of exactly 8 hours starting from a specified hour, say ti (0 <= ti <= 23), exactly from the start of the hour mentioned. That is, if the ith applicant is hired, he/she will work starting from ti o'clock sharp for 8 hours. Cashiers do not replace one another and work exactly as scheduled, and there are enough cash registers and counters for those who are hired.

You are to write a program to read the R(i) 's for i=0..23 and ti 's for i=1..N that are all, non-negative integer numbers and compute the least number of cashiers needed to be employed to meet the mentioned constraints. Note that there can be more cashiers than the least number needed for a specific slot.

Input

The first line of input is the number of test cases for this problem (at most 20). Each test case starts with 24 integer numbers representing the R(0), R(1), ..., R(23) in one line (R(i) can be at most 1000). Then there is N, number of applicants in another line (0 <= N <= 1000), after which come N lines each containing one ti (0 <= ti <= 23). There are no blank lines between test cases.

Output

For each test case, the output should be written in one line, which is the least number of cashiers needed.
If there is no solution for the test case, you should write No Solution for that case.

Sample Input

1
1 0 1 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1
5
0
23
22
1
10

Sample Output

1

Source



又是一道差分约束。

设num[ i ]为i时刻能够开始工作的人数,x[ i ]为实际雇佣的人数, 设r[ i ]为i时刻至少需要工作的人数, s[ I ]=x[ 1 ]+x[ 2 ]…+x[ I ]

有如下关系:

x[ I ]<=num[ I ]

x[ I-7 ]+x[ I-6 ]+x[ I-5 ]+x[ I-4 ]+x[ I-3 ]+x[ I-2 ]+x[ I-1 ]+x[ I ]>=r[ I ]

0<=s[ I ]-s[ I-1 ]<=num[ I ], 1<=I<=24 s[I]-s[ I-8 ]>=r[ I ], 8<=I<=24 s[ I ]-s[ I+16 ]>=r[ I ]-sum, 1<=I<=7

s[0]=0

s[24]-s[0]>=sum(冯威的论文少了这个条件,看了别人的解题报告,才发现。想想也是,sum是枚举的当前最小值,s[24]是实际工作的工人,那么其一定大于sum) 

#include <cstdio>
#include <cstring>
using namespace std;
#define N 26
#define M 1000
#define INF 0x7f7f7f7f

struct Edge
{
	int s,t,w;
}edge[M];

int r[N];
int t[N];
int d[N];
int n,cnt,ans;

void add(int s,int t,int w)
{
	edge[cnt].s = s;
	edge[cnt].t = t;
	edge[cnt ++].w = w;
}

void buildgragh(int x)
{
	int i;
	cnt = 48;
	for(int i = 1; i <= 16; i ++) add(i + 8, i, - r[i + 8]);
	for(int i = 17; i <= 24; i ++) add(i - 16, i, x - r[i - 16]);
	add(24, 0, - x);
}

int SPFA()
{
	for(int i = 0; i <= 24; i ++) d[i] = INF;
	d[0] = 0;
	for(int i = 0; i <= 24; i ++)
		for(int j = 0; j < cnt; j ++)
			if(d[edge[j].s] + edge[j].w < d[edge[j].t])
				d[edge[j].t] = d[edge[j].s] + edge[j].w;
	for(int j = 0; j < cnt; j ++)
		if(d[edge[j].s] + edge[j].w < d[edge[j].t])
			return 0;
	return 1;
}

void Besearch(int low,int high)
{
	if(low > high) return;
	int mid = (low + high) / 2;
	buildgragh(mid);
	if(SPFA())
	{
		ans = mid;
		Besearch(low, mid - 1);
	}
	else Besearch(mid + 1, high);
}

int main()
{
	int T, x;
	scanf("%d",&T);
	while(T --)
	{
		memset(t,0,sizeof(t));
		for(int i = 1; i <= 24; i ++) 
			scanf("%d",&r[i]);
		scanf("%d",&n);
		for(int i = 1; i <= n; i ++)
		{
			scanf("%d",&x);
			t[x + 1] ++;
		}
		cnt = 0;
		for(int i = 1; i <= 24; i ++)
		{
			add(i - 1, i, t[i]);
			add(i, i - 1, 0);
		}
		ans = -1;
		Besearch(0,n);
		if(ans == -1) printf("No Solution\n");  
        else printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值