POJ1236 Network of Schools(tarjan缩点)

Network of Schools
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20366 Accepted: 8028

Description

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B 
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school. 

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2


题意:给出一个有向图,求   最少几个点为起点可以遍历整张图,添加多少条有向边可以让整个图强连通


首先用tarjan缩点为块,缩点后每个块内的点都属于一个强连通分量,所以不用考虑,只需要考虑块与块之间连边即可

第一问,缩块以后入度为0的点的个数

强连通图的性质:任意点的出入度>=1,因此我们只需要找出入度为0的块与出度为0的块,找出他们中的较大值,即为第二问

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string.h>
using namespace std;
const int N=105;
int dfn[N],vis[N],low[N],block[N],dfs_num,col_num,top,st[N],id[N],od[N];
vector<int>e[N];
void Tarjan(int u)
{
    dfn[u]=low[u]=++dfs_num;
    vis[u]=1;
    st[top++]=u;
    for(int j=0;j<e[u].size();j++)
    {
        int v=e[u][j];
        if(!dfn[v])
        {
            Tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(vis[v])
            low[u]=min(low[u],dfn[v]);
    }
    int v;
    if(low[u]==dfn[u])
    {
        col_num++;
        do
        {
            v=st[--top];
            block[v]=col_num;
            vis[v]=0;

        }while(v!=u);
    }
}
void solve(int n)
{
    for(int i=1;i<=n;i++)
        if(!dfn[i])Tarjan(i);
        if(col_num==1)
        {
            puts("1\n0");
            return;
        }
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<e[i].size();j++)
        {
            int v=e[i][j];
            if(block[i]==block[v])continue;
            id[block[v]]++;
            od[block[i]]++;
        }
    }
    int a=0,b=0;
    for(int i=1;i<=col_num;i++)
    {
        if(!id[i])a++;
        else if(!od[i])b++;
    }
    printf("%d\n%d\n",a,max(a,b));
}
int main()
{
    int n,x;
    cin>>n;
    for(int i=1;i<=n;i++)
        while(cin>>x,x)
        e[i].push_back(x);
    solve(n);

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值