HDU-1518-Square

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1518

Square                              


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes


#include<iostream>
#include<cmath>
#include<algorithm>
#include<iomanip>
#include<cstring>
#include<queue>
using namespace std;
int n,m;
int flag=0;
int a[111];       
double sum=0;
int vis[111];
//目前所搜索到所求正方形的边数num,当前的长度len,所搜索到的边数的数组的位置, 
void dfs(int num,int len,int pos)
{
    if(num==4)
    {
        flag=1;
        return;
    }
    if(len==sum/4)
    {
        dfs(num+1,0,1);
    }
    //新的dfs重新走,它走标记没走过的点 
    for(int i=pos;i<=m;i++)
    {
        if(a[i]+len<=sum/4&&!vis[i])
        {
            vis[i]=1;
            //这个棍子还没跑完。 
            dfs(num,len+a[i],i+1);
            if(flag) return;
            //回溯。 
            vis[i]=0;
        }
    }
}
int main()
{      
   cin>>n;
   while(n--)
   {
       cin>>m;
       memset(vis,0,sizeof(vis));
       sum=0;
       int max1=0;
       flag=0;
       for(int i=1;i<=m;i++)
       {
           cin>>a[i];
           sum+=a[i];
           if(a[i]>max1)
           max1=a[i];
       }
        //如果小于4条边,或者平均值小于最大的那条边 一定是不行的。 
        if(m<4||sum/4<max1)
        {
           cout<<"no"<<endl;
           continue;
        }
        dfs(0,0,0);
        if(flag)
    	cout<<"yes"<<endl;
        else 
	    cout<<"no"<<endl;
   }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值