出现身份验证错误,要求的函数不支持,

出现身份验证错误,要求的函数不支持,
这可能是由于CredSSP加密Oracle修正
在五月10号的时候,自己的win10系统突然提示升级,升级完成后就再也远程连接上阿里云的ECS服务器,一直提示这个错误,官方提供了出现这个问题的原因。

配置策略一:客户端的策略为未修补,服务器端策略为强制更新的客户端。

配置策略二:客户端策略为强制更新的客户端,服务器端策略为未修补。

配置策略三:客户端的策略为缓解,服务器端策略为未修补。

只要有一种都会出现,然后官方也提供了3种解决方法,可能刚开始的时候没有足以尝试,今天试了第二种方法,在自己电脑上配置了一下,结果能成功连接ECS了,下面是这个官网连接:
https://help.aliyun.com/knowledge_detail/71931.html用到的方法是:

a.单击 开始 > 运行,输入 regedit,单击 确定。

b.定位到 HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters 键。如果 CredSSP 或者 Parameters 键不存在,请新建 CredSSP 或者 Parameters 键。

c.在 Parameters 键下新建 DWORD 值 AllowEncryptionOracle,并设置数据为 2。

在我自己的电脑上没有找到HKLM ,可能型号不同,我的是HKEY_LOCAL_MACHINE\Software……后面相同。通过这种方法配置过即可连接实例,中间可以根据需求重启电脑(自己的没有重启,直接连接成功)
其实官方提供的方法还是很正确的,多看看多试试,就会解决。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37852553/article/details/80320673
个人分类: ECS
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭