Minimum Inversion Number

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
10
1 3 6 9 0 8 5 7 4 2

Sample Output
16

题意
给你一个逆序数,每次把第一个数移到最后,问n-1种序列中逆序数的最小值

代码

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int l,r,n;
}tree[50010];
void build(int l,int r,int t)
{
	tree[t].l=l;
	tree[t].r=r;
	tree[t].n=0;
	if(l==r)return;
	build(l,(l+r)/2,2*t);
	build((l+r)/2+1,r,2*t+1);
}
void query(int l,int r,int k,int t)
{
	tree[t].n++;
	if(l==r)return;
	int mid=(l+r)/2;
	if(mid>=k)
		query(l,mid,k,2*t);
	else 
		query(mid+1,r,k,2*t+1);
}
int find(int l,int r,int k,int t) 
{
	int mid=(l+r)/2;
	if(k<0||k==r)
		return tree[t].n;
	if(mid<k)
		return find(l,mid,-1,2*t)+find(mid+1,r,k,2*t+1);
	return find(l,mid,k,2*t);
}
int main()
{
	int s[50010],i,j,k,l,n,sum,Min;
	while(scanf("%d",&n)!=EOF)
	{
		build(0,n-1,1);
		for(i=0;i<n;i++)
		{
		        sum=0scanf("%d",&s[i]);
			sum+=i-find(0,n-1,s[i],1);
			query(0,n-1,s[i],1);
		}
		Min=sum;
		for(i=1;i<n;i++)
		{
			sum+=n-1-2*s[i-1];
			if(sum<Min)
				Min=sum;
		}
		printf("%d\n",Min);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值