Linux网络服务--DHCP原理与配置——DHCP中继实验+理论

一、DHCP工作原理

1.1、了解DHCP服务

  • DHCP (Dynamic HostConfiguration Protocol,动态主机配置协议)
  • 由lnternet工作任务小组设计开发
  • 专门用于为TCP/IP网络中的计算机自动分配TCP/IP参数的协议

1.2、使用DHCP的好处

  • 使用DHCP的好处
  • 减少管理员的工作量
  • 避免输入错误的可能
  • 避免IP地址冲突
  • 当更改IP地址段时,不需要重新配置每个用户的IP地址
  • 提高了IP地址的利用率
  • 方便客户端的配置

1.3、DHCP的分配方式

  • 自动分配:分配到一个IP地址后永久使用
  • 手动分配:由DHCP服务器管理员专门指定IP地址
  • 动态分配:使用完后释放该IP,供其它客户机使用

1.4、DHCP租约过程

客户机从DHCP服务器获得IP地址的过程称为DHCP的租约过程

分为四个步骤:

  • 客户端在网络中搜索服务器
  • 服务器向客户端响应服务
  • 客户端向目标服务器发出服务请求
  • 服务器向客户端提供服务

1.4.1、客户机请求IP地址

  • 当一个DHCP客户机启动时,客户机还没有IP地址,所以客户机要通过DHCP获取一个合法的地址
  • 此时DHCP客户机以广播方式发送DHCP Discover发现信息来寻找DHCP服务器

在这里插入图片描述

1.4.2、服务器响应

  • DHCP服务器接收到来自客户机请求IP地址的信息时,在自己的IP地址池中查找是否有合法的IP地址提供给客户机
  • 如果有,DHCP服务器将此IP地址做上标记,加入到DHCPOffer的消息中,然后广播─则DHCP Offer消息

在这里插入图片描述

1.4.3、客户机选择IP地址

  • DHCP客户机从接收到的第一个DHCP Offer消息中提取IP地址,发出IP地址的DHCP服务器将该地址保留,这样该地址就不能再分配给另一个DHCP客户机

在这里插入图片描述

1.4.4、服务器确定租约

  • DHCP服务器接收到DHCP Request消息后,以DHCPACK消息的形式向客户机广播成功确认,该消息包含有IP地址的有效租约和其他可配置的信息
  • 当客户机收到DHCP ACK消息时,配置IP地址,完成TCP/IP的初始化

在这里插入图片描述

1.4.5、重新登陆

  • DHCP客户机每次重新登录网络时,不需要再发送DHCPDiscover信息,而是直接发送包含前一次所分配的IP地址的DHCP Request请求信息

在这里插入图片描述

1.4.6、更新租约

  • 当DHCP服务器向客户机出租的IP地址租期达到50%时,就需要更新租约
  • 客户机直接向提供租约的服务器发送DHCP Request包,要求更新现有的地址租约

二、DHCP服务器的配置

2.1、使用DHCP动态配置主机地址

  • DHCP服务
    1、为大量客户机自动分配地址,提供集中管理
    2、减轻管理和维护成本、提高网络配置效率

  • 可分配的地址信息主要包括
    1、网卡的IP地址、子网掩码
    2、对应的网络地址、广播地址
    3、默认网关地址
    4、DNS服务器地址

2.2、主配置文件

2.2.1、dhcpd.conf的内容构成

在这里插入图片描述

2.2.2、全局配置,作用于整个DHCP服务器

  • ddns-update-style none; ## 禁止dns动态更新

  • default-lease-time 21600; ## 默认租约期限

  • max-lease-time 43200; ## 最大租约期限

  • option domain-name “domain.org”; ## 指定域名

  • option domain-name-servers 202.106.0.20; ## 指定分配dns地址

2.2.3、Subnet网段声明,作用于整个子网段

  • range参数:设置用于分配的P地址池
  • option subnet-mask参数:设置客户机的子网掩码
  • option routers参数:设置客户机的默认网关地址

2.2.4、host主机声明,作用于单个主机

  • hardware ethernet参数:指定对应主机的MAC地址
  • fixed-address参数:指定为该主机保留的IP地址

三、DHCP中继服务实验

3.1、实验拓扑

在这里插入图片描述

3.2、SW2 配置

sysname SW2
#
vlan batch 10 20 30

interface Ethernet0/0/1
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 20
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 30

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

3.3、SW1 配置

sysname RSW1
#
vlan batch 10 20 30

dhcp enable            ###开机自启dhcp服务

interface Vlanif10
 ip address 192.168.10.1 255.255.255.0
un sh
 dhcp select relay
 dhcp relay server-ip 192.168.100.10
#
interface Vlanif20
 ip address 192.168.20.1 255.255.255.0
un sh
 dhcp select relay
 dhcp relay server-ip 192.168.100.10
#
interface Vlanif30
 ip address 192.168.100.1 255.255.255.0
un sh
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094

3.4、服务器配置

在这里插入图片描述

3.5、PC1、PC2配置

PC1,2开启DHCP服务

在这里插入图片描述
在这里插入图片描述

3.6、虚拟机配置

192.168.10.0 网段

yum -y install dhcpd
在虚拟机进入 vi  /etc/dhcp/dhcpd.conf
在里面添加配置文件
注意!逐个PC添加然后保存退出
192.168.10.1网段的PC:
subnet 192.168.10.0 netmask 255.255.255.0{
range 192.168.10.100 192.168.10.200;
option routers 192.168.10.1;
option subnet-mask 255.255.255.0;
option domain-name "www.bdqn1.com";
option domain-name-servers 114.114.114.114,8.8.8.8;
default-lease-time 21600;
max-lease-time 43200;
}
配置完之后
systemctl restart dhcpd  ###配完之后重启一下dhcp服务

然后进入PC1,获取并验证一下
在这里插入图片描述

192.168.20.0 网段

192.168.20.1网段的PC:
subnet 192.168.20.0 netmask 255.255.255.0{
range 192.168.20.100 192.168.20.200;
option routers 192.168.20.1;
option subnet-mask 255.255.255.0;
option domain-name "www.bdqn2.com";
option domain-name-servers 114.114.114.114,8.8.8.8;
default-lease-time 21600;
max-lease-time 43200;
}
systemctl restart dhcpd  ###配完之后重启一下dhcp服务

然后进入PC2,获取并验证一下

在这里插入图片描述

©️2020 CSDN 皮肤主题: 黑客帝国 设计师:上身试试 返回首页