python-PAT甲级题解-1003

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

结尾无空行

Sample Output:

2 4

结尾无空行

Sample Solution:

#用python解题运行时长很吃亏,本例是使用深度优先遍历的一种可行方法

nums=0      #最短路径数
now_length=1e6      #当前最短路径的长度
max_team=0      #当前最多的队伍数

n,m,c1,c2 = map(int,input().split())
teams=list(map(int,input().split()))
roads = [[1e6 for i in range(m)] for i in range(m)]
for i in range(m):
    city1, city2, road = map(int,input().split())
    roads[city1][city2] = road
    roads[city2][city1] = road
flags = [0 for i in range(len(teams))]
    

def dfs(c1:int,c2:int,length:int,team:int):
    global nums,now_length,max_team,roads,teams,flags
    if c1==c2:
        if length<now_length:
            nums=1
            now_length=length
            max_team=team
        elif length==now_length:
            nums+=1
            if max_team<team:
                max_team = team
        return
    elif length<now_length:         #剪枝,length>=now_length时则没有继续进行的必要
        for i in range(len(teams)):
            if flags[i]==0 and roads[i][c1]<1e6:
                flags[i] = 1
                dfs(i,c2,length+roads[i][c1],team+teams[i])
                flags[i] = 0

flags[c1]=1
dfs(c1,c2,0,teams[c1])
print(nums,max_team,end="")

附提交结果

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值