2021-02-06

MPLS实验

在这里插入图片描述

拓扑搭建
在这里插入图片描述

一.实验要求
1.R1与R5MPLS VPN
2.R6与R7MPLS VPN
3.R7可以访问R2/3/4的环回
二.配置思路
1.配置路由器接口、环回IP地址
2.公网内使用ospf建立邻居,加载路由表
R2
ospf 1 router-id 2.2.2.2
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 23.1.1.1 0.0.0.0
R3/4可参考R2
R7配置缺省指向公网即可.
ip route-static 0.0.0.0 0.0.0.0 47.1.1.1
3.R2/4使用BGP、重发布、VPN实现区域间互通
1)R2/3/4建立BGP邻居
R2
bgp 1
router-id 2.2.2.2
peer 4.4.4.4 as-number 1
peer 4.4.4.4 connect-interface LoopBack1
network 2.2.2.0 255.255.255.0
peer 4.4.4.4 next-hop-local
R4参考R2
2)MPLS的配置
配置MPLS – LDP
[r2]mpls lsr-id 2.2.2.2 必须先定义mpls的router-id,要为本地设备的真实ip地址,且邻居可达,因为
该地址将用于建立TCP会话,建议使用环回地址
[r2]mpls 再开启mpls协议
[r2-mpls]mpls ldp 再激活LDP协议
之后需要在所有标签经过的接口上开启协议
[r2-GigabitEthernet0/0/2]mpls 先开启MPLS
[r2-GigabitEthernet0/0/2]mpls ldp 再激活LDP协议
3)配置MPLS VPN
[r2]ip vpn-instance a 创建名为a的vrf空间
[r2-vpn-instance-a]ipv4-family 进入IPV4的配置模式下
[r2-vpn-instance-a-af-ipv4]route-distinguisher 1:1 RD值
[r2-vpn-instance-a-af-ipv4]vpn-target 1:1 RT值 必须对端的PE端一致
[r2]interface GigabitEthernet 0/0/0 进入链接CE端的接口
[r2-GigabitEthernet0/0/0]ip binding vpn-instance a 关联到vrf空间
[r2-GigabitEthernet0/0/0]ip address 192.168.2.2 24 配置私有ip地址
在关联到vrf空间前不能配置接口ip,否则该地址的直连路由将进入公有路由表
题中要求R1/5间使用静态
R1
ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2
R2
ip route-static vpn-instance a 192.168.1.0 255.255.255.0 192.168.2.1
R4
ip route-static vpn-instance a 192.168.4.0 255.255.255.0 192.168.3.2
R5
ip route-static 192.168.1.0 255.255.255.0 192.168.3.1
ip route-static 192.168.2.0 255.255.255.0 192.168.3.1
R6/7间使用动态协议
R6
rip 1
undo summary
version 2
network 192.168.1.0
network 192.168.2.0
R2
bgp 1 ipv4-family vpn-instance b
import-route rip 1
rip 1 vpn-instance b
undo summary
version 2
import-route bgp
R7
ospf 2 router-id 7.7.7.7
area 0.0.0.0
network 192.168.3.2 0.0.0.0
network 192.168.4.2 0.0.0.0
R4
bgp 1
ipv4-family vpn-instance b
import-route ospf 2
ospf 2 router-id 4.4.4.4 vpn-instance b
import-route bgp
三.实验结果
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页