HDOJ1009 FatMouse‘ Trade

链接:Problem - 1009 (hdu.edu.cn)

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500

题目大意:

就是花猫粮买到最多的豆,运用贪心算法。

解题思路:

首先先计算每一磅猫粮可以换多少豆,然后进行排序,用猫粮先买每一磅换的最多的豆,不够就按单价*数量计算。

代码实现:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

const int  N=1010;
struct node{
    int mao;
    int dou;
    double avg;
}p[N];

bool cmp(node a,node b){
    return a.avg>b.avg;
}

int main(){
    int m,n;
    while(cin>>m>>n&&(m!=-1||n!=-1)){
        for(int i=0;i<n;i++){
            cin>>p[i].dou>>p[i].mao;
            p[i].avg=(double)p[i].dou/p[i].mao;//求每斤猫粮可以换多少豆子
        }
        sort(p,p+n,cmp);//进行排序
        double cnt=0;//用来计数
        for(int i=0;i<n;i++){
            if(m<p[i].mao) {cnt+=m*p[i].avg;break;}//猫粮不够,按单价计算
            else {//猫粮够
                cnt+=(double)p[i].dou;//直接加豆子数
                m-=p[i].mao;//剩余猫粮数
            }
        }
        printf("%.3lf\n",cnt);      
    }
    return 0;
}                                                                     

出现的BUG:

1、忘记打换行符。

2、内存开放不够一开始设N为100,但要求开1000个内存空间。

3、cnt为浮点数,p[i].dou是整形,第一次忘记转换。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值