Uva400 Unix ls

6 篇文章 0 订阅
2 篇文章 0 订阅

Subject

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right. 

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 ≤ N ≤ 100). There will then be N lines each containing one left-justified filename and the entire line’s contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set {._-} (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty. Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file. 

Output 

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R + 1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben 

 Sample Output

 Analysis

从题目的输出案例中,可以看出题目的意思是找到最大length的Filename,该Filename的length就是M,即最右一列的字符串长度为M(不够的补空格),其他列的字符串长度为M+2(不够的补空格),输出完整的表格
这其中涉及的Key:

  • 找到M——遍历
  • 根据题目要求,求出rows和columns(一行的最大长度为60)
    列数=(一行的最大长度60-最右列的长度M)/ (M+2)+1
    根据题目要求:列是从左到右先满左,行数=(n-1) / 列数 + 1
  • 对于输入的Filename,用sort进行字典序排序
  • 因为输出的时候只能一行一行输出,不能一列一列输出,不难求出,对排好序后的Filenames,下标为行的倍数就表示下一列,即每一次输出的时候把差为4的都输出为一行就可以

AC CODE

#include <bits/stdc++.h>
using namespace std;
#define maxm 60
#define maxn 105
int n;
string s, filename[maxn];

void print(const string &s, int len, char extra)
{
	cout << s;
	//不够的补空格
	for (int i = 0; i < len - s.size(); i++)
		cout << extra;
}
int main()
{
	while (cin >> n)
	{
		int m = 0;
		for (int i = 0; i < n; i++)
		{
			cin >> filename[i];
			//string.size()是std::size_t,要转换成int
			m = max(m, (int)filename[i].size());
		}
		print("", 60, '-');
		cout << endl;
		sort(filename, filename + n);
		//calculate the rows and columns
		int cols = (maxm - m) / (m + 2) + 1;
		int rows = (n - 1) / cols + 1;
		for (int r = 0; r < rows; r++)
		{
			for (int c = 0; c < cols; c++)
			{
				//r相当于换行,r=0时表示第一行,c表示换列,c=0时表示第一列
				int k = c * rows + r;
				if (k < n)
					print(filename[k], c == cols - 1 ? m : m + 2, ' '); //c是最后一列吗 是的话长度为m,不是的话长度为m+2
			}
			cout << endl;
		}
	}
	return 0;
}
//默写代码...

 我一开始最大的困难就是:看不懂题目什么意思(bushi

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

linengcs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值