【寒假每日一题】洛谷 P2871 [USACO07DEC]Charm Bracelet S

题目链接:P2871 [USACO07DEC]Charm Bracelet S - 洛谷 | 计算机科学教育新生态 (luogu.com.cn)

题目描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有 N 件物品和一个容量为 M 的背包。第 i 件物品的重量是 Wi,价值是 Di。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

输入格式

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

第一行:物品个数 N 和背包大小 M。

第二行至第 N + 1 行:第 i 个物品的重量 Wi 和价值 Di。

输出格式

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

输出一行最大价值。

样例 #1

样例输入 #1

4 6
1 4
2 6
3 12
2 7

样例输出 #1

23

AC code:(01背包问题,并将二维状态数组转化为一维状态数组)

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 3410;
const int M = 12900;

int n,m;
int v[N],w[N];
int f[M];

int main()
{
	cin>>n>>m;
	for(int i = 1 ; i <= n ; i ++)
		cin>>v[i]>>w[i];
	
	for(int i = 1 ; i <= n ; i ++)
	{
		for(int j = m ; j >= v[i] ; j --)
		{
			f[j] = max(f[j] , f[j - v[i]] + w[i]);
		}
	}
	cout<<f[m];
	
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值