Triangle

Triangle

题面翻译

题目描述

给定 4 4 4 根木棍的长度,如果它们中存在 3 3 3 根木棍可以组成三角形,输出 TRIANGLE;如果它们无法组成三角形,但是它们中存在 3 3 3 根木棍可以组成退化的三角形(任意两边之和大于等于第三边,但是不是三角形),输出 SEGMENT;否则,输出 IMPOSSIBLE

注意: 木棍不能折断,也不能只用一部分长度。

输入格式

一行 4 4 4 个整数, 4 4 4 根木棍的长度。

输出格式

如果它们中存在 3 3 3 根木棍可以组成三角形,输出 TRIANGLE;如果它们无法组成三角形,但是它们中存在3根木棍可以组成退化的三角形,输出 SEGMENT;否则,输出 IMPOSSIBLE

By @PC_DOS

题目描述

Johnny has a younger sister Anne, who is very clever and smart. As she came home from the kindergarten, she told his brother about the task that her kindergartener asked her to solve. The task was just to construct a triangle out of four sticks of different colours. Naturally, one of the sticks is extra. It is not allowed to break the sticks or use their partial length. Anne has perfectly solved this task, now she is asking Johnny to do the same.

The boy answered that he would cope with it without any difficulty. However, after a while he found out that different tricky things can occur. It can happen that it is impossible to construct a triangle of a positive area, but it is possible to construct a degenerate triangle. It can be so, that it is impossible to construct a degenerate triangle even. As Johnny is very lazy, he does not want to consider such a big amount of cases, he asks you to help him.

输入格式

The first line of the input contains four space-separated positive integer numbers not exceeding 100 — lengthes of the sticks.

输出格式

Output TRIANGLE if it is possible to construct a non-degenerate triangle. Output SEGMENT if the first case cannot take place and it is possible to construct a degenerate triangle. Output IMPOSSIBLE if it is impossible to construct any triangle. Remember that you are to use three sticks. It is not allowed to break the sticks or use their partial length.

样例 #1

样例输入 #1

4 2 1 3

样例输出 #1

TRIANGLE

样例 #2

样例输入 #2

7 2 2 4

样例输出 #2

SEGMENT

样例 #3

样例输入 #3

3 5 9 1

样例输出 #3

IMPOSSIBLE

思路

本道题题目已经说了很清楚了,只要存在3个满足三角形的两边之和大于第三边就是标准三角形,如果是大于等于第三边就是凑合的三角形。

根据这一点,我们可以用dfs进行暴搜索(组合搜索)

  • 细节1:注意搜完的时候优先级,只有当它不是标准三角形的时候才是凑合三角形。

代码

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 5;

int w[N];
bool st[N];
int q[N],cnt;
int f;

void dfs(int u,int start){
    if(u==4){
        if(q[0]<q[1]+q[2]&&q[1]<q[2]+q[0]&&q[2]<q[0]+q[1]){
            f=1;
        }
        
        if(q[0]<=q[1]+q[2]&&q[1]<=q[2]+q[0]&&q[2]<=q[0]+q[1]&&f!=1){
            f=-1;
        }
        
        return;
    }
    
    for(int i=start;i<=4;i++){
        q[cnt++]=w[i];
        dfs(u+1,i+1);
        cnt--;
    }
}

int main(){
    for(int i=1;i<=4;i++){
        cin>>w[i];
    }
    
    sort(w+1,w+1+4);
    
    dfs(1,1);
    
    if(f==1){
        puts("TRIANGLE");
    }else if(f==-1){
        puts("SEGMENT");
    }else{
        puts("IMPOSSIBLE");
    }
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值