7-1 检查密码

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

参考代码如下:

import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;

public class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int count = Integer.parseInt(sc.nextLine());
        while(count<1||count>100) count = Integer.parseInt(sc.nextLine());
        for(int i = 0; i<count; i++){
            String str = sc.nextLine();
            int l = str.toCharArray().length;
            if(l==0||l>80){
                i--;
            }
            else{
                check(str);
                if(i<count-1) System.out.println();
            }
        }
    }
    public static void check(String str){
        char[] c = str.toCharArray();
        if(c.length<6){
            System.out.print("Your password is tai duan le.");
            return;//返回方法调用处
        }
        else{
            String pat1 = "[a-zA-Z0-9]";//单字符,为字母或数字
            String pat2 = "\\.";//“.”在正则表达式里是“除换行符之外的任意字符”,而这里想表达的是小数点,所以要转义,“\\.”就表示小数点“.”
            String pat3 = "[a-z]*[A-Z]*[a-z]*\\.*[a-z]*[A-Z]*[a-z]*"; //只有字母和小数点
            String pat4 = "\\d*\\.*\\d*";//只有数字和小数点
            Pattern p1 = Pattern.compile(pat1);
            Pattern p2 = Pattern.compile(pat2);
            Pattern p3 = Pattern.compile(pat3);
            Pattern p4 = Pattern.compile(pat4);
            Matcher m3 = p3.matcher(str); Matcher m4 = p4.matcher(str);
            for(int j = 0; j<c.length; j++){
                Matcher m1 = p1.matcher(String.valueOf(c[j]));
                Matcher m2 = p2.matcher(String.valueOf(c[j]));
                if(!m1.matches()&&!m2.matches()){
                    System.out.print("Your password is tai luan le.");
                    return;//返回方法调用处
                }
            }
            if(m3.matches()){
                System.out.print("Your password needs shu zi.");
            }
            else if(m4.matches()){
                System.out.print("Your password needs zi mu.");
            }
            else System.out.print("Your password is wan mei.");
        }
    }
}

注意转义字符的使用。

欢迎留言讨论、补充其他解决方法。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值