L2-008 最长对称子串

1.题目

L2-008 最长对称子串
分数 25

全屏浏览

切换布局
作者 陈越
单位 浙江大学
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:
输入在一行中给出长度不超过1000的非空字符串。

输出格式:
在一行中输出最长对称子串的长度。

输入样例:
Is PAT&TAP symmetric?
输出样例:
11

2.分析

        用双指针进行判断,就是坑点就是asa和assa,要进行分别判断。

3.代码

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main()
{
    int max1 = 0, max2 = 0;
    string str;
    getline(cin, str);
    for (int i = 0; i < str.size(); i++){
        int mid = i, l = i, r = i, count = 0;
        while (str[r] == str[l]){
            count++;
            if (--l<0 || ++r>str.size()) break;
        }
        count= count*2-1;
        max1 = max1 > count ? max1 : count;
    }
    for (int i = 0; i < str.size(); i++){
        int mid = i, l = i, r = i + 1, count = 0;
        while (str[r] == str[l]){
            count++;
            if (--l<0 || ++r>str.size()) break;
        }
        count = count * 2;
        max2 = max2 > count ? max2 : count;
    }
    max1 = max1 > max2 ? max1 : max2;
    cout << max1 << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值