阿里云ECS服务器lxde桌面安装配置
阿里云可以用浏览器中自带远程管理终端,默认Ubuntu或者其他系统都是命令行

web的管理终端可以看到ECS的启动画面,阿里云做的很不错,在此想法可以安装轻量级的桌面,机器只有512MB的内存也能跑起来。

0.ubuntu 16.04 x64
1.lxde 

sudo apt-get install lxde  //full install
aptitude install --without-recommends  //small install

2.Qupzilla
 Internet Browser

sudo apt-get install qupzilla

3.vsftpd

sudo apt-get install vsftpd

4.nginx

sudo apt-get install nginx
sudo leafpad /etc/nginx/sites-available/default

5.安装中文字体,设置语言

 apt-get install language-pack-zh-hans   //langguage pack
 sudo apt-get install fonts-arphic-gbsn00lp fonts-arphic-ukai     //Chinese font  
 sudo apt-get install ttf-wqy-*
 sudo apt-get install xfonts-wqy
 sudo apt-get install fonts-wqy-*  ibus-pinyin

第一步:vi /etc/default/locale (如果没有该文件,可自行创建)
第二步:修改内容,如英文改为中文
LANG='en_US'==>LANG='zh_CN'
LANGUAGE='en_US:en' ==>LANGUAGE='zh_CN:zh'

第三步:重启


6.添加用户

useradd -m user1 -g root   
visudo

7.其它说明:

vsftpd:

 https://www.linuxidc.com/Linux/2017-06/144807.htm


lxde:
 http://blog.nicky1605.com/small-memory-linux-installed-lxde-hang-up.html


vsftpd 

530 login incorrect 的N中情况

 1.密码错误。
 2.检查/etc/vsftpd/vsftpd.conf配置vim /etc/vsftpd/vsftpd.conf
  看下面配置

  local_enable=YES 
  pam_serv ice_name=vsftpd     
   //这里重要,有人说ubuntu是 pam_service_name=ftp,可以试试  
  write_enable=true
 3.检查/etc/pam.d/vsftpd
  vim /etc/pam.d/vsftpd
  注释掉
  #auth    required pam_shells.so
 最后无论哪种情况 重启试试
 sudo service vsftpd restart


阅读更多
个人分类: 软件配置
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

阿里云ECS服务器lxde桌面安装配置

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭