POJ 3667 Hotel

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 9597 Accepted: 4113

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ XiN-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

num数组记录该区间是否住慢,0代表都是空的,1代表都住了人。-1代表有的住了,有的空着。

d[rt][0]代表从区间最左端开始的空的最长长度,d[rt][1]代表从区间最右端开始的空的最长长度,d[rt][2]代表区间的最长空的长度。


#include<cstdio>

#define maxn  51111
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define Max(a,b) (a>b?a:b)

int num[maxn<<2],d[maxn<<2][3];

void PushDown(int rt,int tmp)
{
	if(num[rt]==-1)
		return ;
	num[rt<<1]=num[rt<<1|1]=num[rt];
	if(num[rt]==0)
	{
		d[rt<<1][0]=d[rt<<1][1]=d[rt<<1][2]=(tmp+1)>>1;
		d[rt<<1|1][0]=d[rt<<1|1][1]=d[rt<<1|1][2]=tmp>>1;
	}
	else
	{
		d[rt<<1][0]=d[rt<<1][1]=d[rt<<1][2]=0;
		d[rt<<1|1][0]=d[rt<<1|1][1]=d[rt<<1|1][2]=0;
	}
	num[rt]=-1;
}

void build(int l,int r,int rt)
{
	num[rt]=0;
	for(int i=0;i<3;i++)
		d[rt][i]=r-l+1;
	if(l==r)
		return ;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}

int check(int l,int r,int rt,int D)								//查找满足条件的最左点
{
	if(d[rt][2]<D)
		return 0;
	PushDown(rt,r-l+1);
	int m=(l+r)>>1;
	if(d[rt<<1][2]>=D)
		return check(lson,D);
	if(d[rt<<1][1]+d[rt<<1|1][0]>=D)
		return m-d[rt<<1][1]+1;
	return check(rson,D);
}

void PushUp(int rt,int tmp)
{
	if(d[rt<<1][0] < (tmp+1)>>1)
		d[rt][0]=d[rt<<1][0];
	else
		d[rt][0]=((tmp+1)>>1)+d[rt<<1|1][0];

	if(d[rt<<1|1][1]<tmp>>1)
		d[rt][1]=d[rt<<1|1][1];
	else
		d[rt][1]=d[rt<<1][1]+(tmp>>1);

	d[rt][2]=Max(d[rt<<1][2],d[rt<<1|1][2]);
	d[rt][2]=Max(d[rt][2],d[rt<<1][1]+d[rt<<1|1][0]);
}

void updata(int l,int r,int rt,int L,int R,int flag)
{
	if(l>=L && r<=R)
	{
		num[rt]=flag;
		if(flag==1)
			d[rt][0]=d[rt][1]=d[rt][2]=0;
		else
			d[rt][0]=d[rt][1]=d[rt][2]=r-l+1;
		return ;
	}
	PushDown(rt,r-l+1);
	int m=(l+r)>>1;
	if(L<=m)
		updata(lson,L,R,flag);
	if(R>m)
		updata(rson,L,R,flag);
	PushUp(rt,r-l+1);
}

int main()
{
	int N,M;
	int flag,X,D,tmp;

	while(scanf("%d%d",&N,&M)==2)
	{
		build(1,N,1);

		while(M--)
		{
			scanf("%d",&flag);

			if(flag==1)
			{
				scanf("%d",&D);
				tmp=check(1,N,1,D);
				printf("%d\n",tmp);
				if(tmp!=0)
				{
					updata(1,N,1,tmp,tmp+D-1,1);
				}
			}
			if(flag==2)
			{
				scanf("%d%d",&X,&D);
				updata(1,N,1,X,X+D-1,0);
			}
		}
	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值