hdu 1394 Minimum Inversion Number

15 篇文章 0 订阅
4 篇文章 0 订阅

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequence

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意

有一个数列,a1,a2,a3……an,将a1放在an后面,则又产生一个数列a2,a3,a4……an,a1以此类推,最终有n个数列,计算每个数列中逆序对的个数。

题解

先用线段树求初始时逆序对个数,再递推求出其他解。

首先用build函数清空数组,再依次将ai加入数组中,每次求在数组中比它大的数的个数,时间复杂度为O(nlogn)。

每次对于一个新的数列,若要将首位a1放在最后,则减少的逆序对个数为a1,增加的逆序对个数为n-a1-1。

代码

#include<cstdio>
#include<algorithm>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define N 5010
using namespace std;
int n;
int a[N];
int f[N<<2];

void PushUp(int rt)
{
    f[rt]=f[rt<<1]+f[rt<<1|1];
}

void build(int l,int r,int rt)
{
    f[rt]=0;
    if(l==r)
        return ;
    int mid=(r+l)>>1;
    build(lson);
    build(rson);
}

int query(int L,int R,int l,int r,int rt)
{
    if(l>=L&&r<=R)
        return f[rt];
    int mid=(l+r)>>1;
    int ret=0;
    if(mid>=L)
        ret+=query(L,R,lson);
    if(mid<R)
        ret+=query(L,R,rson);
    return ret;
}

void update(int p,int add,int l,int r,int rt)
{
    if(l==r)
    {
        f[rt]+=add;
        return ;
    }
    int mid=(l+r)>>1;
    if(mid>=p)
        update(p,add,lson);
    else
        update(p,add,rson);
    PushUp(rt);
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        build(1,n,1);
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=query(a[i],n-1,0,n-1,1);
            update(a[i],1,0,n-1,1);
        }
        int ret=sum;
        for(int i=1;i<=n;i++)
        {
            sum+=n-a[i]-a[i]-1;
            ret=min(ret,sum);
        }
        printf("%d\n",ret);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值