hdu3887 Counting Offspring

Counting Offspring

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1148    Accepted Submission(s): 406


Problem Description
You are given a tree, it’s root is p, and the node is numbered from 1 to n. Now define f(i) as the number of nodes whose number is less than i in all the succeeding nodes of node i. Now we need to calculate f(i) for any possible i.
 

Input
Multiple cases (no more than 10), for each case:
The first line contains two integers n (0<n<=10^5) and p, representing this tree has n nodes, its root is p.
Following n-1 lines, each line has two integers, representing an edge in this tree.
The input terminates with two zeros.
 

Output
For each test case, output n integer in one line representing f(1), f(2) … f(n), separated by a space.
 

Sample Input
  
  
15 7 7 10 7 1 7 9 7 3 7 4 10 14 14 2 14 13 9 11 9 6 6 5 6 8 3 15 3 12 0 0
 

Sample Output
  
  
0 0 0 0 0 1 6 0 3 1 0 0 0 2 0
 

Author
bnugong
 

Source
 

Recommend
lcy
 


照样是带时间戳的树状数组,记得去年多校的时候宣姐死活YY不出来……orz,然后我提供了思路,但是不会写,今天终于把他写完了。

注意直接深搜会爆栈,于是乎学了下栈模拟递归的写法……orz。

代码

#include <stdio.h>
#include <string.h>
#include <stack>
#include <vector>
#include <algorithm>
using namespace std;

stack <int> s;
int vis[100005];
int in[100005];
int ans[100005];
int n;
vector <int> v[100005];

int lowbit(int t)
{
    return t&(-t);
}

int Query(int t)
{
    int sum=0;
    while(t>0)
    {
        sum+=in[t];
        t-=lowbit(t);
    }
    return sum;
}

void Add(int t,int val)
{
    while(t<=n)
    {
        in[t]+=val;
        t+=lowbit(t);
    }
}

void DFS(int t)
{
    int tag;
    s.push(t);
    while(!s.empty())
    {
        tag=s.top();
        if (!vis[tag])
        {
            vis[tag]=1;
            ans[tag]=Query(tag);
        }
        else if (v[tag].size()!=0)
        {
            if (vis[v[tag].back()]==0) s.push(v[tag].back());
            v[tag].pop_back();
        }
        else
        {
            ans[tag]=Query(tag)-ans[tag];
            s.pop();
            Add(tag,1);
        }
    }
}

int main()
{
    int m,i,j,T,x,y;
    while(1)
    {
        scanf("%d%d",&n,&m);
        if (n==0 && m==0) break;
        for (i=0;i<=n;i++)
        {
            v[i].clear();
        }
        for (i=0;i<n-1;i++)
        {
            scanf("%d%d",&x,&y);
            v[x].push_back(y);
            v[y].push_back(x);
        }
        memset(in,0,sizeof(in));
        memset(vis,0,sizeof(vis));
        memset(ans,0,sizeof(ans));
        DFS(m);
        for (i=1;i<n;i++)
        {
            printf("%d ",ans[i]);
        }
        printf("%d\n",ans[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值