貌似掉线的博客

疯狂的键盘

Andriod Studio科普篇——3.关于gradle插件的常见问题


1、andriod gradle插件版本过低。

出错位置:

dependencies{
    classpath 'com.android.tools.build:gradle:0.10.2'
}

提示信息:You must use a newer version of the Android Gradle plugin. The minimum supported version is 0.12.0 and the recommended version is 0.12.+

这种情况一般出现在导入其他人的项目,或者更新了android studio之后。原因是android studio是依赖gradle构建的,在构建android项目的时候,会使用到相关的android gradle插件。随着android studio及sdk的更新,可能会导致旧版本的插件不可用(比如在build tools的19.0版本之后,zipalign从tools目录中被移到build tools的对应版本目录中),所以 新版本的android studio会需要更高版本的插件来编译。

按提示,将插件的版本改为0.12.0以上就可以,推荐的版本是使用0.12.+。

2、maven相关问题。

导入项目后出现:Error:(47, 0) No such property: sonatypeRepo for class: org.gradle.api.publication.maven.internal.ant.DefaultGroovyMavenDeployer。

这种问题一般是出现在导入一些开源项目的时候。原因为该项目的原作者会把项目发布到maven中央仓库中,所以在gradle中添加了相关的maven发布任务,而发布任务需要配置username(找不到username也是同样的问题)或sonatypeRepo等属性的值,作者是不会把这些值上传的,所以导致找不到这些属性。你不是该项目的作者,自然不需要这些任务,最干净的方法是把这些任务及引用的maven, signing插件的声明删除即可。当然,你也可以在gradle.properties中添加上找不到的这些属性的值以通过编译。

比如我在gradle.properties中添加上:

#To fix compile error. 这里的三个变量名根据uploadArchives中所引用的变量名不同,具体看情况而配置。
sonatypeRepo=null
sonatypeUsername=null
sonatypePassword=null


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/maosidiaoxian/article/details/37562121
个人分类: Android Studio笔记
相关热词: andriod andriod书
上一篇android修改HOLO对话框风格
下一篇Andriod Studio科普篇——4.关于编译的常见问题
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭