1050. String Subtraction

String Subtraction

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题意

给定两个字符串,要求将第一个字符串中所有属于第二个字符串的字符去除,输出去除后的字符串。

思路

为了达到较高的效率,用散列处理。将第二个字符串中的所有字符进行标记,在第一个字符串中只要去除有标记的字符即可。


代码实现

#include <iostream>
#include <string>
#include <unordered_map>        // 比map效率高
using namespace std;

unordered_map<char, bool> hashTable;    // hash表构建

int main()
{
    string s1, s2;
    getline(cin, s1);
    getline(cin, s2);

    for (int i = 0; i < s2.length(); i++)       // 将在第二个字符串中出现过的字符进行标记
        hashTable[s2[i]] = true;

    for (int i = 0; i < s1.length(); i++)       // 在第一个字符串中只输出没有标记的字符
        if (!hashTable[s1[i]])
            cout << s1[i];

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值