[转发]在eclipse中新建Dynamic web project时选择2.5和3.0的区别

1、Dynamic web project时选择2.5和3.0是指servlet的版本,是2.5的还是3.0的

    servlet3.0以后支持异步

 

2、dynamic web module和对应的TOMCAT 版本

     dynamic web module 2.4  对应Tomcat 5.5
     dynamic web module 2.5  对应Tomcat 6.0

     dynamic web module 3.0 对应Tomcat 7.0


3. tomcat里边的servlet.jar对应哪个版本的java API

     .

4.  (2.5,3.0)的Servlet web.xml 头信息

     

web.xml    (servlet 2.5)

 

Xml代码  收藏代码
  1. <?xml version="1.0" encoding="UTF-8"?>  
  2.    
  3. <web-app xmlns="http://java.sun.com/xml/ns/javaee"  
  4.    
  5. xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  
  6.    
  7. xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"  
  8.    
  9. version="2.5">  
  10.    
  11. </web-app>  

 

web.xml  (servlet 3.0)

 

Xml代码  收藏代码
  1. <?xml version="1.0" encoding="UTF-8"?>  
  2.    
  3. <web-app  
  4.         version="3.0"  
  5.         xmlns="http://java.sun.com/xml/ns/javaee"  
  6.         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  
  7.         xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd">  
  8.    
  9. </web-app>  

 参考:
http://blog.csdn.net/z69183787/article/details/36008097


本微博转自http://www.cnblogs.com/beijingstruggle/p/5461146.html

 

展开阅读全文

没有更多推荐了,返回首页