hdu5754(2016多校第三场,博弈)

202 篇文章 0 订阅
154 篇文章 0 订阅

Life Winner Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1276    Accepted Submission(s): 484


Problem Description
Bo is a "Life Winner".He likes playing chessboard games with his girlfriend G.

The size of the chessboard is N×M .The top left corner is numbered (1,1) and the lower right corner is numberd (N,M) .

For each game,Bo and G take turns moving a chesspiece(Bo first).At first,the chesspiece is located at (1,1) .And the winner is the person who first moves the chesspiece to (N,M) .At one point,if the chess can't be moved and it isn't located at (N,M) ,they end in a draw.

In general,the chesspiece can only be moved right or down.Formally,suppose it is located at (x,y) ,it can be moved to the next point (x,y) only if xx and yy .Also it can't be moved to the outside of chessboard.

Besides,There are four kinds of chess(They have movement rules respectively).

1.king.

2.rook(castle).

3.knight.

4.queen.

(The movement rule is as same as the chess.)

For each type of chess,you should find out that who will win the game if they both play in an optimal strategy.

Print the winner's name("B" or "G") or "D" if nobody wins the game.
 

Input
In the first line,there is a number T as a case number.

In the next T lines,there are three numbers type, N and M .

"type" means the kind of the chess.

T1000,2N,M1000,1type4
 

Output
For each question,print the answer.
 

Sample Input
  
  
4 1 5 5 2 5 5 3 5 5 4 5 5
 

Sample Output
  
  
G G D B

题意很简单,不多描述。

思路:总共四种情况,每种单独去判断就好。

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int con=1,cnt=1,vis[2000]={0},a[1050],b[1050];
    for(int i=2;i<=1000;i++)
    {
        if(vis[i]==0)
        {
            a[con]=i;
            b[con]=a[con]+cnt;
            vis[a[con]]=1;
            vis[b[con]]=1;
            if(b[con]>1000) {con++;break;}
            con++,cnt++;
        }
    }
    int T,t,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&t);
        scanf("%d%d",&n,&m);
        if(n>m)
        {
            int tmp;
            tmp=n;
            n=m;
            m=tmp;
        }
        if(t==1)
        {
            if(n%2==1&&m%2==1)
            {
                printf("G");
            }
            else
                printf("B");
        }
        else if(t==2)
        {
            if(n==m)
                printf("G");
            else
                printf("B");
        }
        else if(t==3)
        {
            if(n==m&&n%3==1)
                printf("G");
            else if((m==n+1)&&(m%3==0))
                printf("B");
            else
                printf("D");
        }
        else
        {
            int flag=0;
            for(int i=0;i<con;i++)
            {
                if(n==a[i]&&m==b[i]) flag=1;
            }
            if(flag)
                printf("G");
            else
                printf("B");
        }
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值