Light--1078(取模运算)

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

解题思路:一开始以为是什么找规律题,找了2个小时,愣是没什么收获,后来才知道,是一道简单的取模运算.但注意题n不一定大于digit.


代码如下:

#include<stdio.h>
int main(){
	long long  n,cas,k,m,s;
	cas=1;
    int t;
    scanf("%d",&t);
    while(t--){
    	m=1;
    	scanf("%lld%lld",&n,&k);
    	s=k;
    	printf("Case %lld: ",cas++);
        if(k%n==0){
        	printf("1\n");
        	continue;
        }
    	while(k!=0){
    		k=(k*10+s)%n;
    		m++;
    	}
    	printf("%lld\n",m);
    }
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值