Fuzhou oj--2221

 Problem 2221 RunningMan

Accept: 7    Submit: 18
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

 Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

 Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

 Sample Input

2100 100
200 100

 Sample Output

No
Yes
解体思路:这是一道找规律题。最优情况是,当对立队为M人,其中一回合排出的人比Runniing man最少的人多一个时,接下来环节就再也派不出比Running man多的人了,此时求出的最小满足条件x,只要Running man队的人多于这个x就行了。

代码如下:
#include<stdio.h>
int main()
{
	int cc;
	scanf("%d",&cc);
	while(cc--)
	{
		int  n,m;
		int r;
		scanf("%d%d",&n,&m);
		if(m%2==0)
		{
			if(n>=3*(m/2)-1)
			printf("Yes\n");
			else
			printf("No\n");
		}
		else
		{
            if(n>=3*(m/2))
            printf("Yes\n");
			else printf("No\n");
            
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值