mac 系统下删除旧的php版本安装最新的php版本及Xdebug的曲折道路

PHP 专栏收录该内容
18 篇文章 0 订阅

      我的2015版的macpro 系统下默认安装了php5.6.28的版本,我用brew 或其它网上的方式安装了php7.0以及php7.1,然而当我打印phpinfo()的时候,我的php5.6.28又出现了,我感觉我有强迫症,我非要搞定它不行,整整浪费了一天多时间,网上的各种方法差不都都试了。然而很多只能借鉴,用处不大,因为每个人的电脑环境可能略有不同。现在搞定了,这里记录一下。

我的第一步是删除我所看到的php版本,我准备将电脑上的所有php全部删干净,然后重新安装一个最新的版本。此操作有风险,须谨慎。网上是这样说的:ps:不建议删除自带的php版本.因为一些软件可能依赖于php环境.虽然可以自编译或使用brew安装新版本的php,但是不建议新手操作.切记操作前.先使用TM备份下系统.以便失误后可以还原文件。

不过你没必要这么做。多一个版本应该也没问题的。删除过程中,user/bin 目录下的可执行文件php 无法删掉,虽然说mac 下有中方式在安全模式下可以删除任何文件的操作,但是我没做,这个文件保留了,还有个php-config, vi打开文件可以看到php版本是最老的,我猜测有可能是这个导致的。

等我觉得其它删除了,我用brew 重新安装了php7.1的版本。这时候你会发现这个目录问题成了头等问题,网上的很多教程和路径,现在都没有了。。 那就跟着这篇文章走吧。

brew 安装完php7.1,下面会有一段东西:

The php.ini and php-fpm.ini file can be found in:

    /usr/local/etc/php/7.1

To enable PHP in Apache add the following to httpd.conf and restart Apache:

    LoadModule php7_module /usr/local/opt/php@7.1/lib/httpd/modules/libphp7.so

    <FilesMatch \.php$>

        SetHandler application/x-httpd-php

    </FilesMatch>

Finally, check DirectoryIndex includes index.php

    DirectoryIndex index.php index.html


The php.ini and php-fpm.ini file can be found in:

    /usr/local/etc/php/7.1/


This formula is keg-only, which means it was not symlinked into /usr/local,

because this is an alternate version of another formula.


If you need to have this software first in your PATH run:

  echo 'export PATH="/usr/local/opt/php@7.1/bin:$PATH"' >> ~/.bash_profile

  echo 'export PATH="/usr/local/opt/php@7.1/sbin:$PATH"' >> ~/.bash_profile


For compilers to find this software you may need to set:

    LDFLAGS:  -L/usr/local/opt/php@7.1/lib

   CPPFLAGS: -I/usr/local/opt/php@7.1/include

To have launchd start php@7.1 now and restart at login:

  brew services start php@7.1

Or, if you don't want/need a background service you can just run:

  php-fpm

这个信息很都有用,它告诉了你一些方法和安装路径。这个信息我是走投无路的时候才去看的,才发现真的不能忽略,没办法按照上面的提示一步一步做。应该都能看懂吧,不能的话可以留言。完了之后别忘记重启php-fpm

下面说一下我重启npm走的弯路

重启php-fpm时有可能会有两种报错,一种是无法找到或打开php-fpm  第二种就是无法按路径找到或打开error_log 

解决第一个错误  

执行 ps aux|grep php-fpm  可以看到php-fpm 的进程

root     21891  0.0  0.0 112660   960 pts/3    R+   16:18   0:00 grep --color=auto php-fpm
root     42891  0.0  0.1 182796  1220 ?        Ss   4月18   0:19 php-fpm: master process (/usr/local/php/etc/php-fpm.conf)
nobody   42892  0.0  0.6 183000  6516 ?        S    4月18   0:07 php-fpm: pool www
nobody   42893  0.0  0.6 183000  6508 ?        S    4月18   0:17 php-fpm: pool www

可以看到上面有个路径,我是将brew 安装路径下的php-fpm.conf,用cp命令copy 到上面这个路径下的。 如果不删除旧的php的话,这个路径下会有一个php-fpm.config.default,可以直接copy 这个文件然后改成php-fpm.conf也可以的。

第二种错误是log 的问题,那就找到对应的php-fpm.conf 打开,里面有log 以及需要对应的地址,找到mac 下log 的地址。我的在/usr/local/var 路径下,改成真实的地址,默认的地址是错误的。

然后重启fpm ,依然没好。

php-fpm --fpm-config /usr/local/etc/php/5.4/php-fpm.conf  --prefix /usr/local/var

执行了这句,发现只要终端不关,php 能用,关了,就挂了。。。

咋好的呢,还是开头优先介绍的。brew services start php@7.1 这句命令

然后我在终端php -v 以及 php-fpm -v

mengdeMacBook-Pro:var GHM$ php-fpm -v
PHP 7.1.16 (fpm-fcgi) (built: Apr 12 2018 03:25:57)
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Xdebug v2.6.0, Copyright (c) 2002-2018, by Derick Rethans
    with Zend OPcache v7.1.16, Copyright (c) 1999-2018, by Zend Technologies
mengdeMacBook-Pro:var GHM$ php -v
PHP 7.1.16 (cli) (built: Apr 12 2018 03:25:50) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Xdebug v2.6.0, Copyright (c) 2002-2018, by Derick Rethans
    with Zend OPcache v7.1.16, Copyright (c) 1999-2018, by Zend Technologies

刚开始我的php-v  显示的是最新的,php-fpm 执行的还是旧的版本。现在说明ok了

再打开网页看下phpinfo()

PHP Version 7.1.16

SystemDarwin mengdeMacBook-Pro.local 16.4.0 Darwin Kernel Version 16.4.0: Thu Dec 22 22:53:21 PST 2016; root:xnu-3789.41.3~3/RELEASE_X86_64 x86_64
Build DateApr 12 2018 03:24:25
Configure Command'./configure' '--prefix=/usr/local/Cellar/php@7.1/7.1.16_1' '--localstatedir=/usr/local/var' '--sysconfdir=/usr/local/etc/php/7.1' '--with-config-file-path=/usr/local/etc/php/7.1' '--with-config-file-scan-dir=/usr/local/etc/php/7.1/conf.d' '--with-pear=/usr/local/Cellar/php@7.1/7.1.16_1/share/php@7.1/pear' '--enable-bcmath' '--enable-calendar' '--enable-dba' '--enable-dtrace' '--enable-exif' '--enable-ftp' '--enable-fpm' '--enable-intl' '--enable-mbregex' '--enable-mbstring' '--enable-mysqlnd' '--enable-opcache-file' '--enable-pcntl' '--enable-phpdbg' '--enable-phpdbg-webhelper' '--enable-shmop' '--enable-soap' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-wddx' '--enable-zip' '--with-apxs2=/usr/local/opt/httpd/bin/apxs' '--with-bz2' '--with-fpm-user=_www' '--with-fpm-group=_www' '--with-freetype-dir=/usr/local/opt/freetype' '--with-gd' '--with-gettext=/usr/local/opt/gettext' '--with-gmp=/usr/local/opt/gmp' '--with-icu-dir=/usr/local/opt/icu4c' '--with-jpeg-dir=/usr/local/opt/jpeg' '--with-kerberos' '--with-layout=GNU' '--with-ldap' '--with-ldap-sasl' '--with-libedit' '--with-libzip' '--with-mcrypt=/usr/local/opt/mcrypt' '--with-mhash' '--with-mysql-sock=/tmp/mysql.sock' '--with-mysqli=mysqlnd' '--with-ndbm' '--with-openssl=/usr/local/opt/openssl' '--with-pdo-dblib=/usr/local/opt/freetds' '--with-pdo-mysql=mysqlnd' '--with-pdo-odbc=unixODBC,/usr/local/opt/unixodbc' '--with-pdo-pgsql=/usr/local/opt/libpq' '--with-pgsql=/usr/local/opt/libpq' '--with-pic' '--with-png-dir=/usr/local/opt/libpng' '--with-pspell=/usr/local/opt/aspell' '--with-unixODBC=/usr/local/opt/unixodbc' '--with-webp-dir=/usr/local/opt/webp' '--with-xmlrpc' '--with-xsl' '--with-zlib' '--with-curl'

坑多,两天了有些我也忘了,谁有遇到问题可以留言。。。

下面说下xdebug 安装

 建议按官方,少走弯路

打开这个xdebug 官方页面

然后command+a 全选,command +v 复制,放到框框里面,运行底部的按钮,会打印出很多我们安装xdebug所需要用到的信息

按步骤走就好了,有一点坑就是,当执行phpsize 的时候报:command cannot find ,这时候找到brew 安装php 的可执行bin目录,直接用那个里面的phpsize 拿来运行,绝对路径运行就可以执行了。还有官方下载的页面有两级目录,而且名字一样,别弄错了,不然运行不了。

  1. Download xdebug-2.6.0.tgz
  2. Unpack the downloaded file with tar -xvzf xdebug-2.6.0.tgz
  3. Run: cd xdebug-2.6.0
  4. Run: phpize (See the FAQ if you don't have phpize.

    As part of its output it should show:

    Configuring for:
    ...
    Zend Module Api No:      20160303
    Zend Extension Api No:   320160303
    

    If it does not, you are using the wrong phpize. Please followthis FAQ entry and skip the next step.

  5. Run: ./configure
  6. Run: make
  7. Run: cp modules/xdebug.so /usr/local/lib/php/pecl/20160303
  8. Edit /usr/local/etc/php/7.1/php.ini and add the line
    zend_extension = /usr/local/lib/php/pecl/20160303/xdebug.so
  9. Restart the webserver

   然后,刷新pathinfo()  ,command+f 查找xdebug

 

    看到这样就成功了

  然后就是配置xdebug 了

  看这哥们的:https://www.cnblogs.com/spareribs/archive/2017/06/27/7084828.html

 

  

 

  • 0
    点赞
  • 2
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值