PostgreSQL ./configure问题

PostgreSQL源码安装时候第一步 ./configure

# ./configure –prefix=/usr/local/postgres-9.3.5 –with-perl –with-tcl –with-python –with-openssl –with-pam –without-ldap –with-libxml –with-libxslt –enable-thread-safety –with-wal-blocksize=16 –with-blocksize=16 –enable-dtrace –enable-debug

问题1:  
checking for dtrace... no  
configure: error: dtrace not found  
解决方法:  
yum search dtrace  
Loaded plugins: fastestmirror, refresh-packagekit, security  
Loading mirror speeds from cached hostfile  
 * base: mirrors.163.com  
 * extras: mirrors.163.com  
 * updates: mirrors.163.com  
=============================================================================================== Matched: dtrace ===============================================================================================  
systemtap-sdt-devel.i686 : Static probe support tools  
systemtap-sdt-devel.x86_64 : Static probe support tools  

找到了,就安装,我是64位的,安装第二个  
[root@localhost postgresql-9.3.5]# yum install -y systemtap-sdt-devel.x86_64
问题2:  
checking for flags to link embedded Perl... Can't locate ExtUtils/Embed.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .).  
BEGIN failed--compilation aborted.  
no  
configure: error: could not determine flags for linking embedded Perl.  
This probably means that ExtUtils::Embed or ExtUtils::MakeMaker is not  
installed.  
解决方法:  
yum install perl-ExtUtils-Embed -y  
问题3:  
configure: error: could not determine flags for linking embedded Perl.  
This probably means that ExtUtils::Embed or ExtUtils::MakeMaker is not  
installed.  
解决方法:  
yum install perl-ExtUtils-Embed  
问题4:  
configure: error: readline library not found  
If you have readline already installed, see config.log for details on the  
failure. It is possible the compiler isn't looking in the proper directory.  
Use --without-readline to disable readline support.  

解决方法:  
yum install readline readline-devel  
问题5:  
checking for inflate in -lz... no  
configure: error: zlib library not found  
If you have zlib already installed, see config.log for details on the  
failure. It is possible the compiler isn't looking in the proper directory.  
Use --without-zlib to disable zlib support.  
解决方法:  
yum install zlib zlib-devel  
问题6:  
checking for CRYPTO_new_ex_data in -lcrypto... no  
configure: error: library 'crypto' is required for OpenSSL  
解决方法:  
yum install openssl openssl-devel  
问题7:  
checking for pam_start in -lpam... no  
configure: error: library 'pam' is required for PAM  
解决方法:  
yum install pam pam-devel  
问题8:  
checking for xmlSaveToBuffer in -lxml2... no  
configure: error: library 'xml2' (version >= 2.6.23) is required for XML support  
解决方法:  
yum install libxml2 libxml2-devel 
问题9:  
checking for xsltCleanupGlobals in -lxslt... no  
configure: error: library 'xslt' is required for XSLT support  
解决方法:  
yum install libxslt libxslt-devel  
问题10:  
configure: error: Tcl shell not found  
解决方法:  
yum install tcl tcl-devel  
问题11:  
checking for ldap.h... no  
configure: error: header file is required for LDAP  
解决方法:  
yum install openldap openldap-devel  
问题12:  
checking for Python.h... no  
configure: error: header file <Python.h> is required for Python  
解决方法:  
yum install python python-devel  
问题13:  
Error when bootstrapping CMake:  
Cannot find appropriate C++ compiler on this system.  
Please specify one using environment variable CXX.  
See cmake_bootstrap.log for compilers attempted.  
解决方法:  
yum install gcc-c++  

参考文献:
http://blog.csdn.net/luojinbai/article/details/44217551

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页