HDU 5464 动态规划

Clarke and problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 96    Accepted Submission(s): 57


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a student and read a book.
Suddenly, a difficult problem appears:
You are given a sequence of number a1,a2,...,an and a number p . Count the number of the way to choose some of number(choose none of them is also a solution) from the sequence that sum of the numbers is a multiple of p ( 0 is also count as a multiple of p ). Since the answer is very large, you only need to output the answer modulo 109+7
 

Input
The first line contains one integer T(1T10) - the number of test cases.
T test cases follow.
The first line contains two positive integers n,p(1n,p1000)
The second line contains n integers a1,a2,...an(|ai|109 ).
 

Output
For each testcase print a integer, the answer.
 

Sample Input
  
  
1 2 3 1 2
 

Sample Output
  
  
2
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
__int64 dp[1002][1002]={0};
int main()
{
    int t=0;
    scanf("%d",&t);
    while(t--)
    {
        int n=0,p=0;
        __int64 s[1005]={0};
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&p);
        for(int i=1;i<=n;i++)
        {
            scanf("%I64d",&s[i]);
        }
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
          for(int j=0;j<=p-1;j++)
          {
                dp[i][j]=(dp[i-1][j]+dp[i-1][(p+j-s[i]%p)%p])%1000000007;
          }
        }
        printf("%I64d\n",dp[n][0]%1000000007);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值