PAT-2019年春季-甲级

7-3 Telefraud Detection (25 分)

Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.

A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. Amakes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.

Input Specification:

Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤10​3​​, the number of different phone numbers), and M (≤10​5​​, the number of phone call records). Then M lines of one day's records are given, each in the format:

caller receiver duration

where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.

Output Specification:

Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

If no one is detected, output None instead.

Sample Input 1:

5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1

Sample Output 1:

3 5
6

Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1had made 5 short phone calls and didn't exceed the threshold 5, and therefore is not a suspect.

Sample Input 2:

5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1

Sample Output 2:

None

 题意大概是警察找嫌疑犯,当一个人与k个以上不同的人打短时间通话,且这些人中只有不超过20%的人给他打电话时,这个人就是嫌疑犯;相互有通话的嫌疑犯被认为是一组;按组内升序,组间按第一个组员升序的格式输出。短时间通话的定义为通话不超过5分钟。
思路:按照通话记录的建立有向图用邻接矩阵存储,第一轮遍历拿到每个人的短时间呼出次数和相应人员对他的的呼入次数;第二轮把满足呼出次数>k且呼入次数*5<呼出次数的放进vector;对vector进行DFS,把存在相互通话的嫌疑犯放进一个临时的vector里面,每次DFS后排序这个vector放到ans里面;排序ans并输出

#include<iostream>
#include<algorithm>
#include<string>
#include<bits/stdc++.h>
#include<vector>
#include<map>
#include<set>
using namespace std;

int call[1005][1005]={0};
int in[1005]={0},out[1005]={0};
int k,n,m;
vector<int>temp;
vector<int>temp1;
vector< vector<int> >ans;
bool vis[1005]={0};
void dfs(int s){
	vis[s]=1;
	temp1.push_back(s);
	vector<int>::iterator it;
	for(it=temp.begin();it!=temp.end();it++)
		if(!vis[*it]&&call[s][*it]&&call[*it][s]) dfs(*it);	
}

int main(){
	cin>>k>>n>>m;
	for(int i=0;i<m;i++){
		int x,y,d;
		cin>>x>>y>>d;
		call[x][y]+=d;
	}//放弃使用vector转而使用邻接表易更改
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			if(call[i][j]!=0&&call[i][j]<=5){
			    ++out[i];
				if(call[i][j]!=0)++in[i];	
			}		
		}	
	} 
	for(int i=1;i<=n;i++)
		if(out[i]>k&&out[i]>=in[i]*5)
		    temp.push_back(i);
	sort(temp.begin(),temp.end());
	vector<int>::iterator it;
	for(it=temp.begin();it!=temp.end();it++){
		if(!vis[*it]){
			temp1.clear();
			dfs(*it);
			sort(temp1.begin(),temp1.end());
			if(!temp1.empty())ans.push_back(temp1);			
		}
	}
	if(ans.empty()){
		cout<<"None"<<endl;
		return 0;
	}
	sort(ans.begin(),ans.end());
	for(int i=0;i<ans.size();++i){
		for(int j=0;j<ans[i].size();++j){
			if(j!=0) cout<<" ";
			cout<<ans[i][j];
		}
		cout<<endl;
	}
	return 0;
}

https://blog.csdn.net/weixin_40688413/article/details/88082779 抄这位大神的

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值