彭世瑜的博客

记录我的code历程 个人主页:www.pengshiyu.com

fabric.api No module named api

导入报错

from fabric.api import *
ImportError: No module named 'fabric.api'

解决

经过网上查阅,发现是版本的问题,高版本把这个模块移除了,安装个低版本就行

这里写图片描述

截图出处:http://docs.fabfile.org/en/latest/upgrading.html

卸载原有模块,重新指定版本安装,下面这个可以

pip install fabric==1.14.0
阅读更多

扫码向博主提问

去开通我的Chat快问

mouday

非学,无以致疑;非问,无以广识
  • 擅长领域:
  • python
  • python爬虫
  • python全栈
版权声明:本文为博主原创文章,欢迎转载,请注明出处 https://blog.csdn.net/mouday/article/details/80692495
个人分类: python error
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭