UVa10165 - Stone Game

2 篇文章 0 订阅

Problem E.Stone Game 

Background

  Jack and Jim are playing an interesting stone game. At the beginning of the game there are N pile(s)of stones. Each pile has Pi (I=1..N, 1<=Pi<=2*109) stones. They take turns to take away some of the stones. There are some rules: they must choose one pile at a time. They can take away any number of stones except 0, of course, not bigger than the number of stones in the pile. One who takes away the last stone will win the game. Jack is the first to fetch the match, and Jim is the second. Now Jack asks you for help, to decide while facing some initializations whether he is sure to win or not.

 

Input

The input file contains several scenarios. Each of them consists of 2 lines:

  The first line consists of a number N. The second line consists of N numbers, meaning Pi (I=1..M). There is only one space between two border numbers.

  The input file is ended with N=0.

 

Output

  For each scenario, print a line containing ‘Yes’ if he is sure to win, or ‘No’ otherwise.

 

Sample Input

1

100

3

1 5 1

4

1 1 1 1

0

 

Sample Output

Yes

Yes

No



NIM取子,只不过胜利状态改变。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int n;
int main(){

    while(~scanf("%d",&n)&&n){
        int ans = 0;
        for(int i = 0; i < n; i++){
            int a;
            scanf("%d",&a);
            ans ^= a;
        }
        if(ans==0) printf("No\n");
        else printf("Yes\n");

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值