HDU1007(分治算法)

Quoit Design

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43000 Accepted Submission(s): 11172

Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output
0.71
0.00
0.75

题目意思是:平面上有好多点,让你找到一个最大的圆圈能把每个点都套进去同时圈不相交。其实就是找点与点之间最小距离,因为数据比较大所以要优化。看了http://blog.csdn.net/allenjy123/article/details/6627751
的解释和代码,讲的很好,把他的代码读懂,改成自己习惯的姿势交了一发ac了。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "cmath"
#include "algorithm"
#define MAXN 100005
using namespace std;
typedef struct Point
{
    double x,y;
}Point;
Point point[MAXN],px[MAXN],py[MAXN];
double get_dis(Point p1,Point p2)
{
    return sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
}
bool cmpx(Point p1,Point p2)
{
    return p1.x<p2.x;
}
bool cmpy(Point p1,Point p2)
{
    return p1.y<p2.y;
}
double min(double a,double b){return a<b?a:b;}
//-------核心代码------------//
double closest(int s,int e)
{
    if(s+1==e)
        return get_dis(px[s],px[e]);
    if(s+2==e)
        return min(get_dis(px[s],px[s+1]),min(get_dis(px[s+1],px[e]),get_dis(px[s],px[e])));
    int mid=(s+e)>>1;
    double ans=min(closest(s,mid),closest(mid+1,e));//递归求解
    int i,j,cnt=0;
    for(i=s;i<=e;i++)//把x坐标在px[mid].x-ans~px[mid].x+ans范围内的点取出来
    {
        if(px[i].x>=px[mid].x-ans&&px[i].x<=px[mid].x+ans)
            py[cnt++]=px[i];
    }
    sort(py,py+cnt,cmpy);//按y坐标排序
    for(i=0;i<cnt;i++)
    {
        for(j=i+1;j<cnt;j++)//py数组中的点是按照y坐标升序的
        {
            if(py[j].y-py[i].y>=ans)
                break;
            ans=min(ans,get_dis(py[i],py[j]));
        }
    }
    return ans;
}
int main()
{
    int i,n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&point[i].x,&point[i].y);
            px[i]=point[i];
        }
        sort(px,px+n,cmpx);
        double distance=closest(0,n-1);
        printf("%.2lf\n",distance/2);
    }

}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值