在安装达梦DM8时,报错无法打开APS服务

在安装达梦DM8时报错无法打开APS服务

在这里插入图片描述
GLIBC2.14需要升级到2.17版本,重新安装部署

先下载glic2.17版本,

Mkdir /xxx/glibc-2.17
Mkdir build;cd build
 ../configure --prefix=/usr --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin

(此时又报错

configure: WARNING:
*** These auxiliary programs are missing or incompatible versions: msgfmt
*** some features will be disabled.
*** Check the INSTALL file for required versions.
checking LD_LIBRARY_PATH variable... contains current directory
configure: error:
*** LD_LIBRARY_PATH shouldn't contain the current directory when
*** building glibc. Please change the environment variable
*** and run configure again. 

解决办法是修改

~/.bash_profile
export LD_LIBRARY_PATH=/usr/local/glibc2.17 export LD_LIBRARY_PATH

之后source生效 再执行一次config就可以了)
之后执行make -j 8&make install
安装完成之后查看版本strings /lib64/libc.so.6 |grep GLIBC
在这里插入图片描述

更新完成后打开APS服务成功)))
进行操作前须先检查oracle状态

su - oracle
lsnrctl start
export ORACLE_SID=PROD
sqlplus '/as sysdba'
startup
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页