HDOJ 1021 Fibonacci Again

1.Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34181    Accepted Submission(s): 16516


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

2.代码

#include <stdio.h>
int main()
{
	int i=0;
	while(scanf("%d",&i)!=EOF)
		printf("%s\n",i%4==2?"yes":"no"); 试着找一下规律每4个中的第二个为“yes”
	return 0;
}

/*
#include <stdio.h>            也正确但是太慢了。
int a[1000000]={0};
int main()
{
	
	a[0]=7%3;
	a[1]=11%3;
	int i,n;
	for(i=2;i<1000000;i++)
		a[i]=(a[i-1]+a[i-2])%3;
	while(scanf("%d",&n)!=EOF)
	{
		if(a[n]==0)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
*/

很好奇如何将代码缩减到60多B,不过这是我现在能弄的最简代码了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值