Ubuntu18.04安装SSH服务时报错The following packages have unmet dependencies:解决办法

在Ubuntu18.04使用命令安装SSH时,报了错误The following packages have unmet dependencies:等等

sudo apt install openssh-server

 

提示说是openssh-server 依赖于 openssh-client 而实际上 openssh-client 已经是最新版本了。首先想到的是先卸载再重新安装一下试了一下果然成功了。

  1. sudo apt-get  autoremove  openssh-client openssh-server 
  2. sudo apt-get install openssh-client openssh-server
  3. sudo /etc/init.d/ssh start

 

重启ssh ,测试成功

可以使用

netstat -tlp

来确认 ssh-server 已经正常工作。如果显示如下图所示则成功安装了ssh。

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值