poj_2362


Language: Default
Square
Time Limit:3000MS Memory Limit:65536K
Total Submissions:17120 Accepted:5902

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 25
bool vis[MAX];
int stick[MAX];
int n,goal;
bool ans;

bool cmp(int a, int b)
{
	return a > b;
}

void dfs(int now, int index, int cnt)
{
	if(cnt == 3)
	{
		ans = true;
	}
	if(ans) return;
	for(int i = index; i < n; i++)
	{
		if(vis[i])
		{
			continue;
		}
		if(now + stick[i] == goal)
		{
			vis[i] = true;
			dfs(0, 0, cnt + 1);
			vis[i] = false;
		}
		else if(now + stick[i] < goal)
		{
			vis[i] = true;
			dfs(now + stick[i], i + 1, cnt);
			vis[i] = false;
			if(now == 0) 
			{
				break;
			}
		}
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	int t, Max, sum;
	cin >> t;
	while (t--)
	{
		cin >> n;
		sum = 0;
		Max = -1;
		for(int i = 0; i < n; i++)
		{
			cin >> stick[i];
			sum += stick[i];
			Max = max(Max, stick[i]);
		}
		goal = sum / 4;
		if(sum % 4)
		{
			cout << "no" << endl;
			continue;
		}
		if(Max > goal)
		{
			cout << "no" << endl;
			continue;
		}
		sort(stick, stick + n, cmp);
		memset(vis, false, sizeof(vis));
		ans = false;
		dfs(0, 0 , 0);
		if(ans)
		{
			cout << "yes" << endl;
		}
		else
		{
			cout << "no" << endl;
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值