zoj_3710Friends

Friends

Time Limit:2 Seconds Memory Limit:65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less thankfriends in common, they will become friends in several days. Currently, there are totallynpeople in the country, andmfriendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integerT(about 100) indicating the number of test cases. ThenTcases follow. For each case, the first line contains three integersn, m, k(1 ≤n≤ 100, 0 ≤mn×(n-1)/2, 0 ≤kn, there will be no duplicated friendship) followed bymlines showing the current friendship. Theithfriendship contains two integersui, vi(0 ≤ui, vi<n,ui≠ vi) indicating there is friendship between personuiandvi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4
 
STL set + map
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<string>
#include<queue>
#include <stack>
using namespace std;
#pragma warning(disable : 4996)

int main()
{
	freopen("in.txt", "r", stdin);
	map<int, set<int> >Map;
	set<int>::iterator it;
	int t, n, m, k, x, y, ans, num, i, j;
	bool flag;
	scanf("%d", &t);
	while (t--)
	{
		Map.clear();
		scanf("%d %d %d", &n, &m, &k);
		while (m--)
		{
			scanf("%d %d", &x, &y);
			Map[x].insert(y);
			Map[y].insert(x);
		}
		flag = true;
		ans = 0;
		while (flag)
		{
			flag = false;
			for (i = 0; i < n; i++)
			{
				for (j = i + 1; j < n; j++)
				{
					if(Map[i].find(j) != Map[i].end())
					{
						continue;
					}
					num = 0;
					for (it = Map[i].begin(); it != Map[i].end(); it++)
					{
						if(Map[j].find(*it) != Map[j].end())
						{
							num++;
						}
					}
					if(num >= k)
					{
						ans++;
						Map[i].insert(j);
						Map[j].insert(i);
						flag = true;
					}
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
昨天训练赛这样写就WA,想不明白
 
 
for (it = Map[i].begin(); it != Map[i].end(); it++)
{
	if(Map[j].find(*it) != Map[j].end())
	{
		num++;
		if(num >= k)
		{
			ans++;
			flag = true;
			Map[i].insert(j);
			Map[j].insert(i);
			break;
		}
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值