对称博弈(菜狗)

After hh has learned how to play Nim game, he begins to try another coin game which seems much easier. 

 


The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous) 
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 

 

Your job is to find out who will definitely win the game.

 

 

The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case. 
Each case contains two integers N(3<=N<=10 9,1<=K<=10).

 

Output

For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)

 

Sample Input

 

23 13 2

 

Sample Output

 

Case 1: firstCase 2: second

游戏是这样的: 
两个玩家用一圈n个硬币开始游戏。 
他们依次从圈子中拿走硬币,每次他们可以拿1〜K连续硬币。 
(想象一下,十个硬币编号从1到10,K等于3,因为1和10是连续的,你可以拿走连续的10,1,2,但是如果2被拿走,你不能拿1,3 ,4,因为1和3不连续) 
拿最后一枚硬币的玩家赢得比赛。 
假设这两名球员总是采取最好的举措,从不犯错误。 
你的工作是找出谁肯定会赢得比赛。

 

 

对于这道题而言,可以有三种情况:
①k等于1    一次最多只能拿1个(每堆只有一个),那就是看奇偶了。
②n≤k  这种情况,那肯定先拿的赢。
③ 这条就是对称博弈了, 除了上述两种情况外的情况(n>k && k!=1)

 

 

    (这时候,无论你第一个人拿什么,怎么拿,后手的人完全可以在第一个人拿的对称的地方做同样的事情。

 

这样,后手就一定会取得胜利,因为最后一步是后手走的。)

 

 


第三条自己在本上画一画就不难发现了。
#include<stdio.h>
int main()
{
    long long int n,a,b,c;
    int i;
    scanf("%lld",&n);
    for(i=1; i<=n; i++)
    {
        scanf("%lld%lld",&a,&b);
        if(b==1)
        {
            if(a%2==0)
                printf("Case %d: second\n",i);
            else
                printf("Case %d: first\n",i);
        }
        else
        {
            if(a<=b)
                printf("Case %d: first\n",i);
            else
                printf("Case %d: second\n",i);
        }
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值