hdu1013Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 88565    Accepted Submission(s): 27601


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
 
 
24 39 0
 

Sample Output
 
 
6 3

知识点:合九法;一个数的数字跟等于这个数模9,也等于各个为所有数之和模9(对9取余的余数)

注意;当这个数是9或是9的倍数时,它的数字跟就等于9!

代码:

#include<stdio.h>
int main()
{
	int s;
	char c;
	while(1)
	{
		s=0;
		while(scanf("%c",&c)&&c!='\n')
			s+=c-'0';
		if(!s)return 0;
		else if(s%9==0)puts("9");
		else printf("%d\n",s%9);
	}
	return 0;
}

注意不能输入数字直接取余,因为这个数可能太大用long long都存不下,所以将要处理的这个数每位都看作一个字符输入,然后减去‘0’,求和对9取余,这样就会好很多比如10的20次方是一个很大的的数。如果用字符来看的话它只有二十个字符

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值