HDU - 5707 Combine String(DP)


Combine String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2208    Accepted Submission(s): 623


Problem Description
Given three strings  a b  and  c , your mission is to check whether  c  is the combine string of  a  and  b .
A string  c  is said to be the combine string of  a  and  b  if and only if  c  can be broken into two subsequences, when you read them as a string, one equals to  a , and the other equals to  b .
For example, ``adebcf'' is a combine string of ``abc'' and ``def''.
 

Input
Input file contains several test cases (no more than 20). Process to the end of file.
Each test case contains three strings  a b  and  c  (the length of each string is between 1 and 2000).
 

Output
For each test case, print ``Yes'', if  c  is a combine string of  a  and  b , otherwise print ``No''.
 

Sample Input
      
      
abc def adebcf abc def abecdf
 

Sample Output
      
      
Yes No
 

Source
 

Recommend
liuyiding

题意: 有a、b、c三个串,当且仅当a、b都为c的字串时输出yes,否则输出no

#include <bits/stdc++.h>

const int N = 2e3 + 10;
int dp[N][N];
char a[N], b[N], c[N];

int main()
{
    while(~scanf("%s %s %s",a , b, c))
    {
        memset(dp,0,sizeof(dp));
        int flag=0;
        int la = strlen(a), lb = strlen(b), lc = strlen(c);
        dp[0][0] = 1;
        for(int i = 0;i <= la; i++){
            for(int j = 0; j <= lb; j++){
                if(a[i] == c[i+j]){
                    dp[i+1][j] |= dp[i][j];
                }
                if(b[j]==c[i+j]){
                    dp[i][j+1] |= dp[i][j];
                }
            }
        }
        if(dp[la][lb] && lc == la + lb) printf("Yes\n");
        else printf("No\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值