uvaoj-1586:分子量

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3 H4 O3 , identifies each constituent element by its chemicalsymbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.In this problem, we assume that the molecular formula is represented by only four elements, C' (Carbon),H’ (Hydrogen),O' (Oxygen), andN’ (Nitrogen) without parentheses.The following table shows that the standard atomicweights for C',H’,O', andN’.Atomic Name Carbon Hydrogen Oxygen Nitrogen Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/molFor example, the molar mass of a molecular formula C6 H5 OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).Given a molecular formula, write a program to compute the molar mass of the formula.

Input

Your program is to readfrom standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemicalsymbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2 n 99) .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input



4

C

C6H5OH

NH2CH2COOH

C12H22O11

Sample Output



12.010

94.108

75.070

342.296


题解:简单的模拟题,在lrj的书上这种题算是简单的不可思议的题目了,(主要是我被虐的太多次了)。。
但是讽刺的是没能一次ac,因为忘记保留小数了,cout默认是保留两位小数,记错成三位了,下面是代码,也许不够优化,但绝对是正确的;

code:
#include <iostream>
#include <cstring>
#include <cctype>
#include <iomanip>
using namespace std;

char alp[5]="CHON";
double g[4]={12.01,1.008,16.00,14.01};
int main()
{
    int t;
    cin>>t;
    char s[1005];
    while(t--)
    {
        cin>>s;
        int len=strlen(s);
        int n=0;//计次器;
        double ans=0;//累加器;
        for(int i=0; i<len; i++)
        {
            for(int j=0; j<4; j++)
            {
                if(s[i]==alp[j])
                {
                    if(isupper(s[i+1])||s[i+1]=='\0')//因为为下标1的时候会省略,所以用这种方法来判定;
                    {
                        ans+=g[j];
                        continue;
                    }
                    else
                    {
                        int k=i+1;//用这个方法纯粹是因为不喜欢直接改循环变量,用另外的变量来代替可以减少错误率;
                        while(isdigit(s[k]))
                        {
                            n=n*10+s[k]-'0';
                            k++;
                        }
                        i=k-1;
                        ans+=(n*1.0)*g[j];
                        n=0;//重新赋值;
                        break;
                    }
                }
            }
        }
        cout<<fixed<<setprecision(3)<<ans<<endl;//保留小数点的方法,但是不推荐。。
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值