sudo apt-get install libncurses5-dev不能成功安装的解决办法

在编译完U-boot.bin文件后,在编译Linux内核时,为了能够 make menuconfig ,所以要使用sudo  apt-get install  libncurses5-dev

但却遇到下面问题


解决方法

首先,运行sudo apt-get update 来更新Ubuntu,如遇到错误则将 /etc/apt/sources.list  的源内容替换为以下内容后sudo apt-get update 再运行apt-getinstall libncurses5-dev 即可,具体方法可参考  http://wiki.ubuntu.org.cn/Qref/Source  以及   http://forum.ubuntu.org.cn/viewtopic.php?t=268843

UBUNTU9.10的更新源内容可参考如下,如果是新版本的的话建议点击以上两个连接,获得好点的更新源

debhttp://tw.archive.ubuntu.com/ubuntu/ karmic main universe restricted multiverse

debhttp://tw.archive.ubuntu.com/ubuntu/ karmic-updates universe main multiverserestricted

debhttp://tw.archive.ubuntu.com/ubuntu/ karmic-proposed universe main multiverserestricted

debhttp://tw.archive.ubuntu.com/ubuntu/ karmic-security universe main multiverserestricted

debhttp://tw.archive.ubuntu.com/ubuntu/ karmic-backports main multiverserestricted universe

deb-src http://tw.archive.ubuntu.com/ubuntu/karmic main universe restricted multiverse

deb-srchttp://tw.archive.ubuntu.com/ubuntu/ karmic-security universe main multiverserestricted

deb-srchttp://tw.archive.ubuntu.com/ubuntu/ karmic-updates universe main multiverserestricted

deb-srchttp://tw.archive.ubuntu.com/ubuntu/ karmic-proposed universe main multiverserestricted

deb-src http://tw.archive.ubuntu.com/ubuntu/karmic-backports universe main multiverse restricted


ubuntu可以通过apt的方式来升级、卸载、管理软件

apt 一些命令的简单介绍如下:

apt-cache search # ------(package 搜索包)
apt-cache show #------(package 获取包的相关信息,如说明、大小、版本等)
sudo apt-get install # ------(package 安装包)
sudo apt-get install # -----(package - - reinstall 重新安装包)
sudo apt-get -f install # -----(强制安装?#"-f= --fix-missing"当是修复安装吧...)
sudo apt-get remove #-----(package 删除包)
sudo apt-get remove - - purge # ------(package 删除包,包括删除配置文件等)

sudo apt-get update #------更新源
sudo apt-get upgrade #------更新已安装的包
sudo apt-get dist-upgrade # ---------升级系统
sudo apt-get dselect-upgrade #------使用dselect 升级
apt-cache depends #-------(package 了解使用依赖)
apt-cache rdepends # ------(package 了解某个具体的依赖?#当是查看该包被哪些包依赖吧...)
sudo apt-get build-dep # ------(package 安装相关的编译环境)
apt-get source #------(package 下载该包的源代码)
sudo apt-get clean && sudo apt-get autoclean # --------清理下载文件的存档 && 只清理过时的包
sudo apt-get check #-------检查是否有损坏的依赖

阅读更多
个人分类: 嵌入式开发—linux
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭