FatMouse' Trade

大一玩过一年的ACM,偶然在杭电ACM oj看到自己曾经刷的题,现在居然连题目类型都说不出了。。。。

FatMouse’ Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

我AC 过的代码,不知道我在写啥。。。。。

#include<stdio.h>
#include<stdlib.h>
#define MAX 10000
struct home
{
    int a;
    int b;
    double c;
}s[MAX];
int cmp(const void *aa,const void *bb)
{
    return ((((struct home *)aa)->c)>(((struct home *)bb)->c))?-1:1;
}
int main()
{
    int m,n,i;
    while(~scanf("%d%d",&m,&n))
    {
        if(m==-1&&n==-1)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].a,&s[i].b);
            s[i].c=(double)(s[i].a*1.0/s[i].b);
        }
        qsort(s,n,sizeof(s[0]),cmp);
        //for(i=0;i<n;i++)
          //  printf("%d %d %.3lf\n",s[i].a,s[i].b,s[i].c);
        double sum=0.0;
        for(i=0;i<n;i++)
        {
            if(m>=s[i].b)
            {
                m-=s[i].b;
                sum+=s[i].a;
              }
            else //if(m<s[i].b)
            {
                sum+=m*s[i].c;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nicehuai

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值