1042 Shuffling Machine (20)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 

 

又是喜闻乐见的学英语环节

 

casino n.
赌场;俱乐部,娱乐场;小别墅

也不认识...不过勉强猜得到

 

simulate

vt.
模拟;模仿;假装,冒充;[生]拟态
adj.
模仿的;假装的

很巧了,今天刚好背到

 

collaborate 

vi.
合作,协作;(国家间的)协调,提携;勾结,通敌

 

inadequate 

adj.
不充足的;不适当的;不足胜任的;信心不足的

这个单词也不认识 有点捞..

 

shuffle 洗牌...真不认识...认识的话可以跳过背景部分了...大概是说传统标准洗牌技术洗牌的人可能和赌徒串通...所以很多赌场搞洗牌机..

 

 

代码直接敲了一遍书上的...

#include<cstdio>
const int N=54;
char mp[5]={'S','H','C','D','J'}; //建立牌的编号与花色的对应关系
int start[N+1],end[N+1],next[N+1]; 
//start为操作前的牌序 
//end为操作后的牌序 
//next数组存放每个位置上的牌在操作后的位置

int main()
{
	int K;
	scanf("%d",&K);
	for(int i=1;i<=N;i++){
		start[i]=i;//初始化牌的编号 
	}
	for(int i=1;i<=N;i++){
		scanf("%d",&next[i]);//输入每个位置的牌在操作后的位置 
	} 
	for(int step=0;step<K;step++){//执行K次操作 
		for(int i=1;i<=N;i++){
			end[next[i]]=start[i];//把第i个位置的牌的编号存于位置next[i] 
		} 
		for(int i=1;i<=N;i++){
			start[i]=end[i]; //把end数组赋值给start数组以供下次操作使用 
		} 
	} 
	for(int i=1;i<=N;i++){
		if(i!=1) printf(" ");
		start[i]--;
		printf("%c%d",mp[start[i]/13],start[i]%13+1); 
	} 
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

云无心鸟知还

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值