HDU 4864(贪心)

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
 
 
1 2 100 3 100 2 100 1
 

Sample Output
 
 
1 50004
 

Author
FZU



代码:

#include<bits/stdc++.h>
using namespace std;
struct point
{
int x,y;
};
point a[100000],b[100000];
int s[150];
bool cmp(point a,point b)
{
if(a.x==b.x)return a.y>b.y;
return a.x>b.x;
}
int main()
{
long long i,n,m,num,money;
while(cin>>n>>m)
{
for(i=1;i<=n;i++)scanf("%d%d",&a[i].x,&a[i].y);
for(i=1;i<=m;i++)scanf("%d%d",&b[i].x,&b[i].y);
sort(a+1,a+1+n,cmp);
sort(b+1,b+1+m,cmp);
num=0;
money=0;
        memset(s,0,sizeof(s));
        int j=1;
        for(int i=1;i<=m;i++)
        {
            while(j<=n&&a[j].x>=b[i].x)
            {
                s[a[j].y]++;
                j++;
            }
            for(int k=b[i].y;k<=100;k++)if(s[k]>0)
           {
               num++;
               money+=500*b[i].x+2*b[i].y;
               s[k]--;
               break;
           }
        }
        printf("%d %lld\n",num,money);
}
return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值