关于 Cocosdx 3.4 中如何使用Scale9Sprite

 相信现在很多刚学Cocos2dx的同学会跟我遇到差不多的问题,就是Cocos2dx的更新实在是太快了,导致有些在书上的方法并不适用。就像我之前在《Cocos2dx 3.X游戏开发之旅》尝试使用Scale9Sprite失败一样,在3.4之前的版本,根据书上

#include "extensions/cocos-ext.h" //引用头文件
USING_NS_CC_EXT; //使用命名空间

然后将libExtensions.vcxproj添加到项目引用即可使用。

但是这个方法在3.4版本是不适用的(一些小伙伴说3.6的版本也是不可以,所以估计在3.4版本之后就开始做了改变)

在新的版本中,使用

#include "ui\UIScale9Sprite.h"
using namespace ui; //这个需要引用,如果不引用会报错
 

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/nizihabi/article/details/46827723
文章标签: c++ Cocos2dx
个人分类: C++ Cocos2dx
上一篇浅谈NGUI中的淡入淡出效果
下一篇cocos compile
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭