【POJ】1753【DFS】【Filp game】【又、全熄灯全亮灯问题】

Description

Flip game is played on arectangular 4x4 field with two-sided pieces placed on each of its16 squares. One side of each piece is white and the other one isblack and each piece is lying either it's black or white side up.Each round you flip 3 to 5 pieces, thus changing the color of theirupper side from black to white and vice versa. The pieces to beflipped are chosen every round according to the followingrules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces tothe left, to the right, to the top, and to the bottom ofthe chosen piece (if there are any).(四周包括自己颜色全变)
    【POJ】1753 <wbr>又、全熄灯全亮灯问题【Flip <wbr>Game】Consider the following positionas an example:

    bwbw
    wwww
    bbwb
    bwwb
    Here "b" denotes pieces lying their black side up and "w" denotespieces lying their white side up. If we choose to flip the 1stpiece from the 3rd row (this choice is shown at the picture), thenthe field will become:

    bwbw
    bwww
    wwwb
    wwwb
    The goal of the game is to flip either all pieces white side up orall pieces black side up. You are to write a program that willsearch for the minimum number of rounds needed to achieve thisgoal.

Input

The input consists of 4 lineswith 4 characters "w" or "b" each that denote game fieldposition.

Output

Write to the output file asingle integer number - the minimum number of rounds needed toachieve the goal of the game from the given position. If the goalis initially achieved, then write 0. If it's impossible to achievethe goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

//看到这个图我就明白了,再次不解释,呵呵~用到位运算,把每一种状态转换为一个int数据

#include <stdio.h>

#include <stdlib.h>

#define MAX 65540

int flag[MAX],step[MAX];//flag[]作为标记,step[]作为记录次数

//用链表很可恶的RE,所以改为顺序队列

#define int_ int  

typedef struct queue{

 int_ *front;

 int_ *rear;

}Queue;

void InitQueue(Queue *Q){

 Q->front=Q->rear=malloc(sizeof(int_)*65536*2);

}

void EnQueue(Queue *Q,int e){

 *(Q->rear++)=e;

}

void GetPop(Queue *Q,int *e){

 *e=*(Q->front++);

}

int Empty(Queue *Q){

 if(Q->front==Q->rear)

  return 1;

 return 0;

}

int main(){

 Queue s;

 int i,j,n=0,m;

 char c;

 InitQueue(&s);

 for(i=0;i<4;i++){

  for(j=0;j<4;j++){

   scanf("%c",&c);

   n<<=1;

   if(c=='b')

    n++;

  }

  getchar();

 }

 if(n==0 || n==65535){

  printf("0\n");

  return 0;

 }

 EnQueue(&s,n);

 flag[n]=1;

 while(!(Empty(&s))){

  GetPop(&s,&n);//对头元素

  for(i=0;i<4;i++)

   for(j=0;j<4;j++){

    m=n;

    if(i==0)//只翻转下一行的同列元素

     m^=1<<(11-4*i-j);//15-4*(i+1)-j

    else if(i==3)//只翻转上一行的同列元素

     m^=1<<(19-4*i-j);//15-4*(i-1)-j

    else{//上下两行

     m^=1<<(11-4*i-j);

     m^=1<<(19-4*i-j);

    }

    if(j==0)//只翻转同行的下一列元素和自身,因为同一列的11即3的2进制

     m^=3<<(14-4*i-j);//15-4*i-j、15-4*i-(j+1)

    else if(j==3)

     m^=3<<(15-4*i-j);//15-4*i-(j+1)、15-4*i-j

    else

     m^=7<<(14-4*i-j);//111即为7的2进制

    if(m==0 || m==65535){

     printf("%d\n",step[n]+1);

     return 0;

    }

    if(!flag[m]){

     EnQueue(&s,m);

     flag[m]=1;

     step[m]=step[n]+1;

    }

   }

 }

 printf("Impossible\n");

 return 0;

}

POJ1753题目为"Flip Game",题目给出了一个4x4的棋盘,每个格子有黑色或白色,每次翻转一个格子会同时翻转它上下左右四个格子的颜色,目标是把整个棋盘都变为同一种颜色,求把棋盘变成同种颜色的最小步数。 解题思路: 一般关于棋盘变色的题目,可以考虑使用搜索来解决。对于POJ1753题目,可以使用广度优先搜索(BFS)来解决。 首先,对于每个格子,定义一个状态,0表示当前格子是白色,1表示当前格子是黑色。 然后,我们可以把棋盘抽象成一个长度为16的二进制数,将所有格子的状态按照从左往右,从上往下的顺序排列,就可以用一个16位的二进制数表示整个棋盘的状态。例如,一个棋盘状态为: 0101 1010 0101 1010 则按照从左往右,从上往下的顺序把所有格子的状态连接起来,即可得到该棋盘的状态为"0101101001011010"。 接着,我们可以使用队列来实现广度优先搜索。首先将初始状态加入队列中,然后对于队列中的每一个状态,我们都尝试将棋盘上的每个格子翻转一次,生成一个新状态,将新状态加入队列中。对于每一个新状态,我们也需要记录它是从哪个状态翻转得到的,以便在得到最终状态时能够输出路径。 在搜索过程中,我们需要维护每个状态离初始状态的步数,即将该状态转换为最终状态需要的最小步数。如果我们找到了最终状态,就可以输出答案,即最小步数。 代码实现:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值